Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2018-07-05 23:52:54

kurt
Member
Registered: 2015-09-03
Posts: 31

Correct PHP version?

My site is hosted by GoDaddy, and using CPanel, they now state that PHP Version 7.2 is now available, and we should check for compatibility.  My site apparently was using v5.4. I tested it with 7.2, and when attempting to view the site, I received an online message that the Shopping cart was disabled, and the entire site was greyed out.

I switched back to 5.4, and all is good.

What is the best version of PHP should we use with Backlight?

Offline

#2 2018-07-06 13:16:56

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,514

Re: Correct PHP version?

We support up to version 7.2. Each of 7.0, 7.1 and 7.2 have caused issues with Backlight in general that we’ve patched as we’ve gone along. It’s likely that you don’t have the latest version of the Cart. If you do want to try 7.2 again, I suggest first downloading the latest zip file for the cart and replacing module-cart.

Offline

#3 2018-07-06 21:32:56

kurt
Member
Registered: 2015-09-03
Posts: 31

Re: Correct PHP version?

Thank you.  I'll try it.  I believed I have the latest, but I'll reload it and advise.

Offline

#4 2018-07-06 21:47:21

kurt
Member
Registered: 2015-09-03
Posts: 31

Re: Correct PHP version?

i updated the Cart as mentioned. 

With 7.2, I received the following message:

count(): Parameter must be an array or an object that implements Countable in SimpleHTMLTag.php on line 44

With 7.1, all is good.

Kurt

Offline

Board footer

Powered by FluxBB