Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-07-16 21:29:03

Sven
Member
Registered: 2016-01-01
Posts: 30

Page error: 404 - Not Found

Hello, after upgrading www.sven-michael.com to 1.0.3, all pages (except home) report back the 404 error: Not Found - The requested URL /contact/ was not found on this server. When trying to reach a page via the menu, it displays the home page without error message.
I've already tried a complete fresh install and set-up, but it doesn't fix the problem.
Galleries, search pages and the preview pages (e.g. http://sven-michael.com/?page=contact) are not impacted.
Andy idea? Many thanks and Krgds
Sven M

Offline

#2 2016-07-16 21:41:29

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,256

Re: Page error: 404 - Not Found

Hi Sven, this will be an issue with the .htaccess file not working correctly on your host.  Can you email me a Backlight admin login via the Email link under my name?

Offline

#3 2016-07-16 21:58:55

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,256

Re: Page error: 404 - Not Found

Thanks for the login Sven.  There is an issue with .htaccess at the top of your site and Bluehost's FastCGI setting.  I have been looking into this and don't yet have a perfect solution. 

There are three ways to fix the links:

1. Rename .htaccess to something else.  This will result in links on your site being in the format ?page=contact. 

2. Edit the .htaccess file and remove the '#' on towards the end of the file so that the end of the file looks like:

	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d

	RewriteRule ^(.*)$ %{ENV:BASE}index.php?%{ENV:QS}&page=$1 [QSA,L]

</IfModule>

This should make links like /contact/ work, with the repercussion that invalid links such as /a/a/c/d will not correctly show up a 404 Not Found page.

3. Disable FastCGI in your host's control panel.  This can be done by logging into your Bluehost control panel and navigating to the PHP Config section.  Select "PHP 5.6" rather than "PHP 5.6 (FastCGI)" to disable FastCGI.

This should result in links such as /contact/ working, and links such as /a/b/c/d/ correctly showing 404 Not Found pages.  The one potential downside may be that FastCGI provides faster performance.  I have not noticed any performance difference between having FastCGI enabled or not.

Option 3 looks like the best solution.

For either 1, 2 or 3, make sure to clear your template cache by clicking Designer > Templates > Clear Template Cache when logged into Backlight.

Offline

#4 2016-07-16 23:33:13

Sven
Member
Registered: 2016-01-01
Posts: 30

Re: Page error: 404 - Not Found

Hi Ben, many thanks!!

Side is working again, so happy.
Nevertheless I wanted to feedback, that I had to add URL links instead of page links into the menu, to make it work:

I've first tried solution 3, but links were still not ok. So I also modified the .htaccess file. After that I've got a wired Masonry layout and on the homepage the error message:
Something went wrong; Unexpected error: Module 'uploadprogress' already loaded in Unknown on line 0. Please report error at http://community.theturninggate.net
but the links (e.g. /contact) were working --> solved by changing to FastCGI (both cPanel and .htaccess file).
Finally the menu links were still inactive (reverting back to home), solved by url links.

Offline

#5 2016-07-17 08:13:11

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,256

Re: Page error: 404 - Not Found

Hi Sven,  I'm glad you got it working. It looks like you've found a 'solution 4'.  Changing the links to 'URL links' is a good work-around.

That error you saw was likely a configuration problem on your host.  There is nothing in Backlight that references 'uploadprogress'.

Offline

#6 2016-07-20 13:56:44

davidmaui
Member
Registered: 2016-07-13
Posts: 7

Re: Page error: 404 - Not Found

Hi, I too am having the issue with pages Sven. Ben sent me some suggestions, I tried but no luck. I know the ttg team is busy, so I thought I would ask you Sven what the complete .htaccess file is suppose to look like. It sounds like you tried turning php to not use 5.6 Fast Cgi and then switched back to using 5.6 Fast CGI. Could you confirm your working settings for php and post the full text of the .htmaccess file using text? I understand setting the direct url, but that isn't working for me either. So I thought I would copy your settings and work from there.

Offline

#7 2016-07-20 14:27:59

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,256

Re: Page error: 404 - Not Found

Hi David, the full source of .htaccess is below.  This should work for either FastCGI or not FastCGI, as-is without any changes.  Only try the suggested changes if it does not work under FastCGI.

# ------------------------------------------------------------------------------
# | Web fonts access                                                           |
# ------------------------------------------------------------------------------

# Allow access from all domains for web fonts

<IfModule mod_headers.c>
	<FilesMatch "\.(eot|font.css|otf|ttc|ttf|woff)$">
		Header set Access-Control-Allow-Origin "*"
	</FilesMatch>
</IfModule>

<IfModule mod_rewrite.c>
	RewriteEngine On

	############################################################################
	# Edit this section for servers using FastCGI

	# For FastCGI (or seeing the error message 'No input file specified.':
	# add # to the start of the next line
	RewriteBase /

	RewriteCond $0#%{REQUEST_URI} ([^#]*)#(.*)\1$

	# For FastCGI (or seeing the error message 'No input file specified.':
	# add # to the start of the next line and remove # from the line after)
	RewriteRule ^.*$ - [E=BASE:%2]
	#RewriteRule ^(.*)$ - [E=BASE:]

	############################################################################



	RewriteRule ^(.*)$ - [E=QS:mod_rewrite=on]

	RewriteRule ^([^\/.]*)-single.php$ %{ENV:BASE}single.php?%{ENV:QS}&id=$1 [QSA,L]

	RewriteRule ^([^\/.]*).css$ %{ENV:BASE}index.php?%{ENV:QS}&extension=css&name=$1 [QSA,L]
	RewriteRule ^([^\/.]*).js$ %{ENV:BASE}index.php?%{ENV:QS}&extension=js&name=$1 [QSA,L]
	RewriteRule ^([^\/.]*).gif$ %{ENV:BASE}index.php?%{ENV:QS}&extension=gif&name=$1 [QSA,L]
	RewriteRule ^([^\/.]*).png$ %{ENV:BASE}index.php?%{ENV:QS}&extension=png&name=$1 [QSA,L]
	RewriteRule ^([^\/.]*).jpg$ %{ENV:BASE}index.php?%{ENV:QS}&extension=jpg&name=$1 [QSA,L]

	#RewriteCond %{QUERY_STRING} !mod_rewrite=on
	#RewriteRule ^index.php$ %{ENV:BASE}index.php?%{ENV:QS} [QSA,L]

	RewriteCond %{QUERY_STRING} !mod_rewrite=on
	RewriteRule ^mobile.php$ %{ENV:BASE}mobile.php?%{ENV:QS} [QSA,L]

	RewriteCond %{QUERY_STRING} !mod_rewrite=on
	RewriteRule ^(.*)download.php %{ENV:BASE}download.php?%{ENV:QS} [QSA,L]
	
	RewriteRule ^$ %{ENV:BASE}index.php?%{ENV:QS} [QSA,L]
	
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d

	RewriteRule ^(.*)$ %{ENV:BASE}index.php?%{ENV:QS}&page=$1 [QSA,L]

</IfModule>

Offline

#8 2016-07-20 15:57:26

davidmaui
Member
Registered: 2016-07-13
Posts: 7

Re: Page error: 404 - Not Found

First off thank you Ben. I really appreciate your help I know you are super busy. I reposted the .htaccess file as is. No luck. under PHP 5.4  or 5.6 Fast CGI with and without the recommended "# Edit this section for servers using FastCGI" I also tried the un-modified .htaccess file without using-FastCGI and same problem. I did get different errors depending on the modification.

The un-modified.htaccess  I get "Internal Server Error 500" with the recommended modifications "Edit this section for servers using FastCGI" I get "404 Error File Not Found" So I will leave it as the modified for FastCGI version for now as it shows my bluehost error page.

This is only happening on pages created in "TTG Pages" my backlight galleries and CRG are working beautifully. I know you are just getting the bugs out, thank you again TTG for making an awesome product. The site I am working on is slowly coming alone. You can see the errors I am mentioning at http://emmawhitney.com/galleries/weddings/ this gets you in to see the gallery links working. The errors are on the (Home) link which is "Link to" URL for testing Sven suggestion, and the other errors are on the (Information) and (Contact) links using "Link to" page in the menu template in Backlight Menu Set.

Ben I sent you new login for BL and FTP feel free to tweak settings if you think of something, and let me know if you want me to change from the current 5.6 FastCGI setting?

Offline

#9 2016-07-21 03:09:47

davidmaui
Member
Registered: 2016-07-13
Posts: 7

Re: Page error: 404 - Not Found

Okay, 100% user error. Not a Backlight issue. I inadvertently deleted the index.php file when I was cleaning out old files from CE3 and 4. I didn't notice because I was not using pages at the time. A week after buying Backlight I added pages and there was no index.php file to write to. MAHALO BEN!

Offline

#10 2016-08-11 01:59:04

capnhooke
Member
From: Chicagoland
Registered: 2016-08-11
Posts: 39
Website

Re: Page error: 404 - Not Found

I'm having the same trouble.  My Home, about and contact pages are giving me a 404 error.  I know just enough web dev to get into trouble so a little help will be very much appreciated. I'm not sure where this [ .htaccess ] file should reside in the /backlight/admin/  file or just in the /backlight/ file?

http://hookephoto.com/newsite/

Offline

#11 2016-08-11 04:32:50

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 17,318
Website

Re: Page error: 404 - Not Found

the .htaccess file should be in the root of the site.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#12 2016-08-11 09:28:07

capnhooke
Member
From: Chicagoland
Registered: 2016-08-11
Posts: 39
Website

Re: Page error: 404 - Not Found

Thanks Rod it all works great.  Much appreciate your advice for many years !
Thom

Offline

Board footer

Powered by FluxBB