Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2014-10-19 08:14:47

Jon
Member
From: Alberta, Canada
Registered: 2012-09-28
Posts: 102
Website

Contact form

I am just about to start upgrading my site to CE4 from CE3. But I just received this message from my ISP about online forms:
-------------------------------
In our efforts to reduce the amount of spam, viruses and offer better security we have instituted inbound and outbound filters for our mail servers. If you are using port 25 for sending mail please make sure you update that to outbound port 587 ASAP. If you are using PHPmail or Sendmail from your hosted website you will need to change that to SMTP authentication using outbound port 587 or your forms will be blocked.
-------------------------------

How does this affect us? What should I be doing to make sure my forms work?

Today I tested my current form (CE3), sending a note from an unrelated address. I got the message through the website okay, but the copy to my unrelated address did not arrive.

TIA.
Jon

Offline

#2 2014-10-19 16:08:26

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,298

Re: Contact form

Hi Jon, you should be able to set the SMTP server details in the TTG BE admin settings.
Login to ttg-be admin, at /ttg-be/ on your server, then on the Settings page complete the Email Configuration
Mail Send Type: smtp
SMTP Host: [your host may need to advise on this.  Perhaps 'localhost'?]
SMTP Username: [leave blank, unless advised by your host]
SMTP Password: [leave blank, unless advised by your host]
SMTP Port: 587
SMTP Security [Protocol: leave as ssl, unless advised otherwise by your host]

Offline

#3 2015-01-08 02:43:31

gcusick
Member
Registered: 2013-03-04
Posts: 23

Re: Contact form

Same problem, since updating my home page (and hence the contact page) from CE3 to CE4.  I have:

1. Installed TTG-BE (Version is 2.0.2)
2. Set up SMTP: ssl, auth.smtp.1and1.co.uk, port 465 or 587, username and password that work elsewhere.

Response is:

fsockopen() [function.fsockopen]: unable to connect to ssl://auth.smtp.1and1.co.uk:587 (Connection timed out)|#0 [internal function]: ErrorHandler::handleError('ssl://auth.smtp...', 587, 110, 'Connection time...', 10) #1 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/lib/SMTP.php(125): fsockopen('ssl://auth.smtp...', 587, 10) #2 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/lib/PHPMailer.php(604): SMTP->Connect() #3 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/lib/PHPMailer.php(520): PHPMailer->SmtpConnect('Date: Wed, 7 Ja...', '--b1_0edecd96b3...') #4 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/lib/PHPMailer.php(413): PHPMailer->SmtpSend() #5 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/helpers/EmailHelper.php(115): PHPMailer->Send() #6 /homepages/42/d20590601/htdocs/webroot/ttg-be/framework/helpers/EmailHelper.php(61): EmailHelper->sendEmailViaSMTP() #7 /homepages/42/d20590601/htdocs/webroot/ttg-be/admin/application/delegates/ContactDelegate.php(67): EmailHelper->send(Array, Array) #8 /homepages/42/d20590601/htdocs/webroot/contact.php(130): ContactDelegate->contact() #9 {main}|URL: /contact.php

I've also tried using smtp.gmail.com, as above but with my correct gmail username and password, with the same result.

I guess that I'm at a loss, and would really appreciate some wise guidance!

Thanks

Offline

#4 2016-07-01 11:53:21

robsoncesco
New Member
Registered: 2016-07-01
Posts: 1

Re: Contact form

Hi gcusick

My form worked correctly for 1 year. But today, began to display an error message similar to yours.

You could solve this problem ?

Thank you.

==============

fsockopen() [function.fsockopen]: SSL: Success|#0 /var/www/html/6co.com.br/web/ttg-be/framework/lib/SMTP.php(125): ErrorHandler::handleError('ssl://smtp.gmai...', 465, 0, '', 10) #1 /var/www/html/6co.com.br/web/ttg-be/framework/lib/PHPMailer.php(604): SMTP->Connect('ssl://smtp.gmai...', 465, 10) #2 /var/www/html/6co.com.br/web/ttg-be/framework/lib/PHPMailer.php(520): PHPMailer->SmtpConnect() #3 /var/www/html/6co.com.br/web/ttg-be/framework/lib/PHPMailer.php(413): PHPMailer->SmtpSend('Date: Thu, 30 J...', '--b1_0c1fec5295...') #4 /var/www/html/6co.com.br/web/ttg-be/framework/helpers/EmailHelper.php(115): PHPMailer->Send() #5 /var/www/html/6co.com.br/web/ttg-be/framework/helpers/EmailHelper.php(61): EmailHelper->sendEmailViaSMTP() #6 /var/www/html/6co.com.br/web/ttg-be/admin/application/delegates/ContactDelegate.php(67): EmailHelper->send() #7 /var/www/html/6co.com.br/web/contact.php(63): ContactDelegate->contact(Array, Array) #8 {main}|URL: /contact.php

Offline

#5 2016-07-01 12:23:30

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,298

Re: Contact form

This is either because your host has blocked the call to Google's SMTP, or you're running into Google's new security settings.

Please see this post on the latter: http://community.theturninggate.net/vie … 389#p38389

Offline

Board footer

Powered by FluxBB