Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-05-11 20:44:49

alfred
Member
Registered: 2013-06-08
Posts: 128

Templates gone after update to 1.0.1

I have just updated to 1.0.1 and when logging in to Backlite I got the update messages (successful) and my test-site looks as before, but when I go to Designer I can't find my templates anymore, they are all gone. Same for Pages and Menu-sets. The uploaded images are also not shown anymore, although the site itself still uses them.

I am pretty sure I have followed the update process as described in the readme. I am not too fuzzed about it, because that's what a test-site is for, but need to understand where I have possibly gone off the rails.

Any suggestions?

Last edited by alfred (2016-05-11 20:45:34)

Offline

#2 2016-05-11 21:00:56

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,717
Website

Re: Templates gone after update to 1.0.1

Did you clear template cache?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#3 2016-05-11 21:06:06

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Templates gone after update to 1.0.1

Yes, I did.

Offline

#4 2016-05-11 22:35:09

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,717
Website

Re: Templates gone after update to 1.0.1

I have just updated to 1.0.1 and when logging in to Backlite I got the update messages (successful) and my test-site looks as before, but when I go to Designer I can't find my templates anymore, they are all gone. Same for Pages and Menu-sets.

You didn't happen to upload the backlight/data folder too did you (or the entire backlight/ folder)? That would explain all the missing templates, pages, and menu sets.

right at the top of the update instructions is this warning:

IMPORTANT: Do NOT replace the entire backlight directory!  Doing so will remove ALL data and settings!


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#5 2016-05-12 01:17:06

mblanchette1
Member
From: Bedford, NH
Registered: 2012-10-15
Posts: 110
Website

Re: Templates gone after update to 1.0.1

I had no problem whatsoever with the update -- all my settings were intact. But you need to look at the README to only copy selected folders.

Offline

#6 2016-05-12 06:17:52

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Templates gone after update to 1.0.1

I am sure I have followed the readme instructions - had the file open and looked at it when doing the update. If I would have overwritten everything, I should not have got the update messages that I got followed by a message that the update was successful, I reckon. It is interesting as well to see that my changes to the menu set are still there, the uploaded masthead is being used, but no uploaded images are shown and I can't see any templates, not even the Default ones.
Have sent my credentials to Ben, let's wait if he can see anything. If that does not work, I'll repeat the update process.

Offline

#7 2016-05-12 06:24:31

johnbrks
Member
From: Los Angeles
Registered: 2015-08-14
Posts: 137
Website

Re: Templates gone after update to 1.0.1

i lost all of my templates too.  i only uploaded the specified files.  when i went into BL admin, it said it was updating.  then i cleared the cache.
(i even redownloaded the zip file today)

the website no longer works and no templates are listed.

if you need any info, let me know.
the site is www.joliverbrooks.com

Offline

#8 2016-05-12 06:33:29

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,077

Re: Templates gone after update to 1.0.1

Hi John, it looks like you've copied backlight/index.php into the top of your site.  Do you think that could be the case?  If so, try coping out the index.php from the top level of the extracted zip file into the top of your domain.

Offline

#9 2016-05-12 06:35:40

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,077

Re: Templates gone after update to 1.0.1

Hi Alfred, can you provide me with a Backlight admin login?  It would also be helpful if you could provide me with an FTP login so I can see what may be amiss with your files.

I doubt that the templates themselves have been removed.  What's more likely the case is that Backlight can't find the modules that the templates are linked to, which would prevent them from being listed.

Offline

#10 2016-05-12 07:23:04

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Templates gone after update to 1.0.1

Hi Ben, I thought I have sent you and email containing both last night? If that has not come through, I need to wait till tonight, because I don't have access to the info right now. Could you check please? Alfred

Offline

#11 2016-05-12 07:30:18

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,077

Re: Templates gone after update to 1.0.1

Hi Alfred, I can't see any emails from you, sorry. What is your sender's name?

Offline

#12 2016-05-12 08:14:23

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Templates gone after update to 1.0.1

Ben, have just sent another email with the login credentials. The PWs have been changed, you can't use those from last night anymore. Alfred

Offline

#13 2016-05-12 09:27:54

johnbrks
Member
From: Los Angeles
Registered: 2015-08-14
Posts: 137
Website

Re: Templates gone after update to 1.0.1

I reupload the upgraded files and now it works.
I have it in the top level because that is where Bluehost wants the primary site

Offline

#14 2016-05-12 21:51:56

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Templates gone after update to 1.0.1

Have cleared my Browser Cache and downloaded and installed the latest Backlight 1.0.1 fix - and things are all fine now! Thanks for the great support. Alfred

Offline

#15 2016-05-12 21:54:00

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 4,077

Re: Templates gone after update to 1.0.1

Great, I'm glad to hear!

Offline

Board footer

Powered by FluxBB