Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2015-05-06 00:30:14

bdfisher
Member
Registered: 2012-09-25
Posts: 27

Galleria and Galleries/Autoindex Problems; Galleria

I am trying to rebuild my website (initially built with CE2) starting with Pages CE4. Since I am using MAMP for testing I am unable to provide a link to the developing site. I am using Lightroom CC on a Mac (OS X 10.9).

The pages I configured displayed as expected in the LR preview. I then loaded the site to the MAMP server location on the Mac.

I have no problems with the About and Contact pages.

Home Page - Galleria
Galleria displays correctly in LR preview. But the following error message appears using Firefox (v. 37.0.2):
“Fatal error: Could not extract a stage height from the CSS. Traced height: 0px.”

However, using Safari (v. 7.1.5), Galleria displays correctly on the home page. Puzzling!

Galleries/Autoindex
AutoIndex (descriptive) appears as expected in LR preview. But it does not appear on the Galleries page in either Firefox or Safari. Only the text insert appears.

I have attempted, unsuccessfully, to find solutions in the support documents and in the forum. Please excuse me if I missed it something!

Other Questions
I have other questions.

1. When I used Galleria in Pages CE2 on the home page I was able to display a frame with a mat insert. (See fisherpix.ca). I do not see a  way to configure this in Pages CE4. Am I missing something or should I be using Stage CE4 for this purpose?

2. Please clarify the effect of Galleria settings options for: "fullscreenCrop" and "image Crop". 

3. Is it possible to use Stage to view a JuiceBox slideshow?

Thanks.

Barry

Offline

#2 2015-05-06 04:01:42

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 17,184
Website

Re: Galleria and Galleries/Autoindex Problems; Galleria

Home Page - Galleria
Galleria displays correctly in LR preview. But the following error message appears using Firefox (v. 37.0.2):
“Fatal error: Could not extract a stage height from the CSS. Traced height: 0px.”

I have a test site in WAMP using Firefox (same version) and don't see this issue.

AutoIndex (descriptive) appears as expected in LR preview. But it does not appear on the Galleries page in either Firefox or Safari. Only the text insert appears.

The Galleries page/Autoindex rely on thumbnails in the galleries within. So you need to have some galleries in the galleries/ folder
(sorry, since it's  a local install I can't tell if you already do have galleries in the galleries/ folder)
more on thumbnails in the autoindex here: http://ce4.theturninggate.net/docs/doku … thumbnails


Other:

1. When I used Galleria in Pages CE2 on the home page I was able to display a frame with a mat insert. (See fisherpix.ca). I do not see a  way to configure this in Pages CE4. Am I missing something or should I be using Stage CE4 for this purpose?

You can try setting a fixed aspect ratio, then set a background color and a border widths. You won't get the exact same look though

2. Please clarify the effect of Galleria settings options for: "fullscreenCrop" and "image Crop".

You can find explanations of Galleria settings over at the Galleria site: http://galleria.io/docs/options/

fullscreencrop: http://galleria.io/docs/options/fullscreenCrop/
imagecrop: http://galleria.io/docs/options/imageCrop/

3. Is it possible to use Stage to view a JuiceBox slideshow?

Not natively. You'd need to use phplugins to insert the code. Probably using ttg_grid_top
http://ce4.theturninggate.net/docs/doku … _phplugins


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#3 2015-05-06 06:36:03

bdfisher
Member
Registered: 2012-09-25
Posts: 27

Re: Galleria and Galleries/Autoindex Problems; Galleria

Thanks very much for your help Rod.

After reading your post, I tried loading the home page using Firefox. Of course, this time it worked fine!

I did not have any galleries installed in the galleries folder (as you suspected!); the reference you provided was very helpful.

Once I have completed setting up my site (and overcome future problems that will undoubtedly occur!) I will attempt to install a JuiceBox slideshow.



Barry

Offline

Board footer

Powered by FluxBB