Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2018-02-16 00:51:46

theomolenaar
Member
Registered: 2012-12-11
Posts: 120

PHP version

Hello

I updated the PHP version at my hosting to 7.2. And both the autoindex and the direct pages did not work anymore.

Function create_function() is deprecated|#0 /mnt/web120/d0/89/51959089/htdocs/_pictures_CE4_V01/wp-includes/pomo/translations.php(208): ErrorHandler::handleError(8192, 'Function create...', '/mnt/web120/d0/...', 208, Array) #1 /mnt/web120/d0/89/51959089/htdocs/_pictures_CE4_V01/wp-includes/pomo/translations.php(269): etc etc...

Switched back to 5.6 and the site worked again........ 

So CE4 does not support PHP 7 ? Or did I miss an upgrade ?

Offline

#2 2018-02-16 01:02:11

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,201
Website

Re: PHP version

There has been some discussion of php 7.2 on the Backlight Support forum.
http://community.theturninggate.net/vie … hp?id=8421

While Ben is looking into updating Backlight to be compatible, I don’t know that CE4 will get the same treatment.
http://theturninggate.net/2017/11/26/en … s-plugins/

for now, I think your only option is to revert to an earlier version of php.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#3 2018-02-16 05:28:51

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,771

Re: PHP version

The above error is raised from within Wordpress, so is not code that we have control over. 
I don't know whether updating Wordpress would fix this.  If not, then your best bet might be to change your site settings to use an older version of PHP, such as 5.6.

Offline

Board footer

Powered by FluxBB