Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-07-03 03:35:00

RPPugh
Member
From: Surrey, UK
Registered: 2013-03-25
Posts: 27
Website

First attemp at Backlight - 2 queries and an oddity!

Hi - just spent the afternoon having my first go with Backlight, and this has raised one query, one real oddity, and one which might be either.

The site is at www.rppugh.co.uk (please ignore the aesthetics for now!!)

1. Query - I have set up a second high level gallery - "family" - which sits alongside the initial backlight "galleries", and successfully published two albums to it. Is there a way for me to apply password protection to "family" so that users sign in once and can then access all albums below it? It appears that I could apply protection to an album set sitting above the galleries, but that would create a redundant level under "family".

2. Oddity - Under galleries, there is an apparent album "Northumbria", which I created within an album set 'family' before I decided to put 'family' as a top level gallery. From LR Publish Services, I deleted the album set 'family', which appeared to delete the album as well. It no longer exists in LR, or on the server, but that odd entry is still there when I click on 'galleries'. Any ideas about how to get rid of it?

3. Query / oddity - the albums under 'family' show thumbnails when I go to 'family', but when I go to 'galleries', the album set 'Botswana' is not showing an image in the thumbnail. What have I done wrong?

All help gratefull received.

Richard

Offline

#2 2016-07-03 06:35:14

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,733
Website

Re: First attemp at Backlight - 2 queries and an oddity!

Is there a way for me to apply password protection to "family" so that users sign in once and can then access all albums below it?

No, not to top level galleries.

Oddity - Under galleries, there is an apparent album "Northumbria", which I created within an album set 'family' before I decided to put 'family' as a top level gallery. From LR Publish Services, I deleted the album set 'family', which appeared to delete the album as well. It no longer exists in LR, or on the server, but that odd entry is still there when I click on 'galleries'. Any ideas about how to get rid of it?

Backlight > Publisher > Top-level galleries.  To the right of the top-level gallery where the album exists, click on Albums. Click on the name of album in question. Scroll down to the bottom of the resulting page and click Delete.

3. Query / oddity - the albums under 'family' show thumbnails when I go to 'family', but when I go to 'galleries', the album set 'Botswana' is not showing an image in the thumbnail. What have I done wrong?

This works just like album sets in CE4. Edit the Album set in Lightroom > Publisher and set the cover image.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#3 2016-07-03 12:31:40

Matthew
Administrator
From: San Francisco, CA
Registered: 2012-09-24
Posts: 5,604
Website

Re: First attemp at Backlight - 2 queries and an oddity!

If you want to password protect families, but still have it appear as a "top-level" set, you could cheat a bit.

Kill the top-level "Family".

Publish a new album set, "Family", under the top-level /galleries location.

In the album set settings, hide from index. This will prevent it appearing on your galleries page. Also, setup your password protection.

In your menu, create a direct link to the "Family" album set.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#4 2016-07-04 00:25:15

RPPugh
Member
From: Surrey, UK
Registered: 2013-03-25
Posts: 27
Website

Re: First attemp at Backlight - 2 queries and an oddity!

Matthew - thanks for the idea about 'hide from album set' - that is now working to give the user experience that I wanted - good thought. Although I had to close the browser (Firefox) down and restart it before the family album set became hidden - clearing the cache was not enough - not particularly intuitive - I only stumbled into it by accident, but I'm glad I did before I fired a reply at you saying that it didn't work!!

Rod - thanks for your help - that got rid of the orphan gallery, and I have now populated the album set thumbnails with images - BUT it appears that 'Random' doesn't work for album sets, even when there are populated albums underneath. If I specify 'Random', I get a blank thumbnail. Is this expected?

But all in all, my first couple of days with Backlight have been impressive - it's going to make it much more likely that I actually get on and set up a proper site! So thank to the Matthew and the team.

Richard

Offline

#5 2016-07-04 00:35:33

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,733
Website

Re: First attemp at Backlight - 2 queries and an oddity!

Although I had to close the browser (Firefox) down and restart it before the family album set became hidden

as long as you're logged into Backlight, you'll see all hidden albums and sets. Your viewers won't though.

BUT it appears that 'Random' doesn't work for album sets, even when there are populated albums underneath. If I specify 'Random', I get a blank thumbnail. Is this expected?

Yes, this is expected and works just like it did with CE4. 'Random' pulls thumbnails from an album or album set thumbnails/ folder. Since Lightroom can't publish images to an album set, no thumbnails are created for an album set's thumbnails/ folder.
If you want to use Random for an album set, then from the Lightroom Library module, export a group of images to represent the album set. Set the dimensions to be the same as for the albums within the set. Then upload them via FTP to the respective album set thumbnails/ folder.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#6 2016-07-04 01:51:02

RPPugh
Member
From: Surrey, UK
Registered: 2013-03-25
Posts: 27
Website

Re: First attemp at Backlight - 2 queries and an oddity!

Thanks - that all makes sense. I'm sure that there will be othewr things that I trip over, but I'm good for now!

R

Offline

Board footer

Powered by FluxBB