Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-06-29 15:52:01

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Watermarks on images?

Does BL support inserting watermarks on images?  How about being able to specify which watermark per image?

I have a standard watermark that I use, but it is a PNG and I have both a white and a black version.  Depending on the image, I may need to use one or the other to have it show appropriately.

Can BL support this?

Offline

#2 2016-06-29 16:08:23

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 355
Website

Re: Watermarks on images?

Have a look at Lightroom Publisher plugin, album preferences.

Rainer

Offline

#3 2016-06-29 20:43:10

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,714
Website

Re: Watermarks on images?

You can apply watermarks on a per album basis, but not a per image basis


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#4 2016-07-02 11:32:00

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

Now I have the opposite problem -- I cannot eliminate the watermark??

I had told LR Publisher to use my PNG watermark, and told all albums to let LR manage watermarks.  It all worked.

Unfortunately, I have found that a universal watermark won't really work -- the color of the watermark and its location need to change to meet the needs of each image.  I therefore told LR Publish to not use watermarks (turned off the check box).  All my images still have the png watermark though?

I then created a blank text watermark.  No text, no shadow, opacity of zero. Called it "Blank" and told LR Publish to use that watermark.  However, it still shows my prior png watermark.

I tried changing the albums to use a different watermark, instead of "let LR manage" -- you guessed it, the png watermark still shows.

How do I now get rid of the universal watermark, so I can use Photoshop to add a specific mark to each image independently?

Offline

#5 2016-07-02 11:52:48

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,714
Website

Re: Watermarks on images?

After making changes like this you will need to republish the images.

Besides the watermarking control in Publisher settings, there's a control under the Features tab of the Create/Edit album dialog box.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#6 2016-07-02 12:42:15

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

I selected every album under TTG Publisher, chose "mark for republish," then pressed the Publish button and waited until it was done.

On Firefox, I then did a refresh of the album page.  When complete, clicked on a photo and scrolled through images.  They all still have the watermark...? sad

Here is one page with the problem -- http://www.mindstormphoto.com/galleries/art/mercado/

(I also switched to Safari, which had never seen this website before, in case there was a caching problem.  Safari also sees the watermarks where there should be none.)

Last edited by mindstorm (2016-07-02 12:44:17)

Offline

#7 2016-07-02 12:57:08

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,714
Website

Re: Watermarks on images?

I selected every album under TTG Publisher, chose "mark for republish," then pressed the Publish button and waited until it was done.

Check to make sure that neither the "Push metadata without updating existing photos" or the "Publish thumbnails without updating other renditions" are checked in Publisher settings.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#8 2016-07-02 13:39:51

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

rod barbee wrote:

I selected every album under TTG Publisher, chose "mark for republish," then pressed the Publish button and waited until it was done.

Check to make sure that neither the "Push metadata without updating existing photos" or the "Publish thumbnails without updating other renditions" are checked in Publisher settings.

Ah... BOTH are checked.  I will try it again after turning those off.

Gonna take awhile for the 970 images in the 29 galleries... smile

Offline

#9 2016-07-02 14:30:57

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

rod barbee wrote:

After making changes like this you will need to republish the images.

Besides the watermarking control in Publisher settings, there's a control under the Features tab of the Create/Edit album dialog box.

The Album dialog has some set to "let Lightroom handle," some to "do not watermark" and some to "<specific watermark>" so that I can test all combinations.

The watermark has been turned on in the TTG Publisher, as has both checkboxes allowing update without changing the main photo.  I then let it publish the set.

All of them still have the blasted png watermark I first created the albums with... sad

An example is here -- http://www.mindstormphoto.com/galleries/art/2014show/

I then created a brand new album, with a single image to test. Told it 'no watermark'.  It works properly.

Example of the new test here -- http://www.mindstormphoto.com/galleries/art/test/

I hope this doesn't mean I am going to have to delete all 29 albums and start from scratch to get rid of that watermark... sad

Offline

#10 2016-07-02 14:34:44

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,714
Website

Re: Watermarks on images?

Uncheck those checkboxes. If they are checked, the photos won't be updated and the watermarks won't be changed.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#11 2016-07-02 14:51:44

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

rod barbee wrote:

Uncheck those checkboxes. If they are checked, the photos won't be updated and the watermarks won't be changed.

Yep, they were turned off, as part of earlier instructions given to me in this thread.

HOWEVER, breakthrough! 

I had the 'features' on each album different to see if any would work.  I just found that if I have the watermark turned off on the Publisher, _and_ the album feature set to "let Lightroom manage watermarks" then the watermark does indeed finally go away!

No other combination of settings seemed to do it.  I am now republishing the entire library again, and hopefully will now have this licked, and the site ready to announce to my adoring public. smile

Offline

#12 2016-07-03 00:40:49

mindstorm
Member
Registered: 2014-07-21
Posts: 94

Re: Watermarks on images?

The entire site got republished overnight, and the errant watermarks are now gone.  Please mark this as resolved...

... and thanks for all your help on this! smile

Offline

Board footer

Powered by FluxBB