Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-05-30 23:46:32

aebolzan
Member
Registered: 2013-04-12
Posts: 92

almost there...but problem with galleries

I have almost finished my upgrade from CE4 to Backlight for my bilingual site. I have finished the Spanish verision first, then downloaded the folder backlight to my PC and uploaded via ftp once again to my site, but this time to the [english] folder. Everything run fine...except that I cannot enter into de galleries (http://agustinbolzan.com.ar/english/galleries/)....what I get is "You don't have permission to access /english/galleries/ on this server."......the structure of my web site is

[backlight]
[galleries]
[english] -> [backlight]
                  [galleries]

the difference I find is that in the first level galleries folder I find the file lib.php, index.php,gallery.xml and .htaccess, but in the second level of galleries (under [english]) I do not find these files......is this normal?

so, what should I do in order to have access to my english galleries?...the rest of the site runs fine....

Agustin

Offline

#2 2016-05-31 00:38:46

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,799
Website

Re: almost there...but problem with galleries

have you published anything to the english/galleries/ folder?
You need to publish to the galleries folder first; Backlight will automatically create those other files.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#3 2016-05-31 00:48:01

aebolzan
Member
Registered: 2013-04-12
Posts: 92

Re: almost there...but problem with galleries

Yes, I have published one gallery there...but cannot access to it...I was thinking to remove the whole [english] folder and restart it from scratch.....but I am not sure if this will solve the problem....

Offline

#4 2016-05-31 01:16:24

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,799
Website

Re: almost there...but problem with galleries

after you uploaded the spanish version to the english folder, did you log into backlight and change the site URL?
Was the .htaccess file copied over to the english folder?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#5 2016-05-31 01:25:23

aebolzan
Member
Registered: 2013-04-12
Posts: 92

Re: almost there...but problem with galleries

yes, I updated the URL and copied also the .htaccess file

Offline

#6 2016-05-31 01:42:44

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,799
Website

Re: almost there...but problem with galleries

just a thought. The backlight/ folder for your main (Spanish) site contains the databases, including the publisher database. It could be that the English site's publisher database is expecting things to be there that just aren't there. This could be causing the error, I'm thinking.

If you're willing here's something to try. Otherwise, wait for Ben to jump in, he might have (and probably does) a better idea.

In Lightroom, delete any albums you've published to the english site.
Make sure you're logged out of english/backlight.
Then, via ftp, delete the /data/publisher folder from the english backlight installation (/backlight/data/publisher)
(you might have noticed that in the backlight download you received from ttg, there is no publisher folder inside the data folder; that gets created by Backlight)

Log back in to backlight. I think this should create the data/publisher folder and its contents
Try publishing to the english/galleries folder.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#7 2016-05-31 01:55:28

aebolzan
Member
Registered: 2013-04-12
Posts: 92

Re: almost there...but problem with galleries

thanks for the suggestion. I will try it this evening once I am at home with LR in front of me. I will let you know if this worked....or not.....but it sounds something possible that the problem is in the publisher due to the copy of the entire spanish blacklight folder to another folder....english folder

Offline

#8 2016-05-31 10:07:19

aebolzan
Member
Registered: 2013-04-12
Posts: 92

Re: almost there...but problem with galleries

You were right!!!.......now everything runs fine!......evidently the problem was with the data in the publisher folder...thanks!

Agustin

Offline

#9 2016-05-31 10:10:27

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,799
Website

Re: almost there...but problem with galleries

Good to hear!


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

Board footer

Powered by FluxBB