Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-05-23 04:49:13

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Menu Woes

Evening Guys,

Having a real issue with my new menu here: http://njp.kopstone.co.uk on my test site!

Created 3 albums. 1 for the Home page, hidden from the galleries album-set and 2 to show.

My Menu has only 3 items: galleries, blog, contact. The last two are set to external urls for testing and the galleries link is set to the galleries album set.

My issue is that; rather than show the 2 albums as a drop-down in hover, the galleries link just points to the home page. The blog and contact menu items continue to point to default locations of /blog and /contact.

I have removed everthing and re-created from scratch etc. etc. I guess I'm missing something simple here.

Any help greatly appreciated.

Offline

#2 2016-05-23 04:57:18

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,733
Website

Re: Menu Woes

have you tried things like clearing the template cache?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#3 2016-05-23 05:02:43

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Re: Menu Woes

Hey Rod,

Yes, cleared template cache, and cleared the browser cache as well. yikes(

Offline

#4 2016-05-23 05:26:54

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,733
Website

Re: Menu Woes

have you tried a forum search? I seem to remember a similar issue in the past week or so. Just can't remember if it was resolved and if it was, what the resolution is.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#5 2016-05-23 13:57:45

Matthew
Administrator
From: San Francisco, CA
Registered: 2012-09-24
Posts: 5,604
Website

Re: Menu Woes

I don't see any drop down menus at all, either on-screen or in the source code. I'm not sure why the "menu-item-has-children" class is being applied to the "galleries" menu when there are no children. Ben will probably need to chime in here. The menu pointing to the wrong place is probably something to do with .htaccess pathing.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#6 2016-05-23 14:49:01

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Re: Menu Woes

Really strange now....

I have removed all items from my menu except the gallleries item. My menu is the only menu and it is assigned to the correct page template. Cleared my browser cache, cleared the template cache and also used an alternate browser. However the 3 menu items still show on the home page! Galleries still points to the home page etc.

I renamed the .httaccess files in the root and in the galleries directory, tried adding url and relative links. Nothing seems to shift what I have on the page yikes(

Offline

#7 2016-05-23 14:53:32

Matthew
Administrator
From: San Francisco, CA
Registered: 2012-09-24
Posts: 5,604
Website

Re: Menu Woes

You might want to kick Ben an email with FTP and admin logins.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#8 2016-05-23 17:09:46

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Re: Menu Woes

OK Matt, will do.

Hi Ben, have sent you an email with login details.

Offline

#9 2016-05-23 17:39:36

tomowensphoto
Member
From: Suffolk
Registered: 2012-11-21
Posts: 258
Website

Re: Menu Woes

Hi Lofty,
I had a problem with some funny nested menu issues that required me to delete rows from the database as orphans had been left behind after deleting via Publisher. I've not recreated the problem as I have been busy preparing for an exhibition. Deleting the orphans cleared the menu issue or at least cleared the redundant Galleries choices from the menu-set combo.
Ben advised me what to do with the access to the database.
Regards,
TomO


Regards,
TomO
Just a simple photographer
Live site at http://tomowens.openpoint.co.uk/

Offline

#10 2016-05-23 18:28:32

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Re: Menu Woes

Ooh, good shout Tom, thanks for the input!

I'll wait for Ben to get back to me, think it's night time in Aussie land right now.....

Offline

#11 2016-05-24 05:09:25

lofty
Member
From: UK
Registered: 2012-09-26
Posts: 256
Website

Re: Menu Woes

OK, that sorted it.

Deleted everything, started again and did it properly this time smile Back on track, but no idea what was going on...

Thanks for your help Ben.

Offline

Board footer

Powered by FluxBB