Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#2 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-23 14:15:54

Rainer Goergen wrote:

Of course, I only use Safari, check my website.

Rainer

I use 450 pixel wide thumbnails, and it appears that pre-sizing thumbnails provides a work-around for the Safari loading problems.  I've converted several dozen album sets or albums with no problems.

The only remaining loading difficulty has been on albums where I use a pre-sized custom-thumbnail hero image at 1920 pixels wide.  This produces an acceptable 450 pixel thumbnail in the album set, but still has sporadic loading problems in Safari.

You have a very nice, smooth-running website.  Enjoyed it thoroughly.  I was wondering how you get the photo frames within the slideshow?

#3 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-21 23:05:59

Rainer Goergen wrote:

All of my custom thumbnails are pre-sized and sharpen with lightroom since I use backlight 2, because they looked unsharp in Safari browser. In Firefox they looked very sharp. But now also in Safari.

Rainer

Have you checked if the thumbnails load properly with Apple Safari?

#4 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-21 18:20:02

More grist for the mill.  Safari seems to be happier loading images if I publish pre-sized custom thumbnails.  I use maximum thumbnail width of 450 px, so I set up all the thumbnails on my Cruises Album Set to pre-sized 450 px. And so far, 14 of the 24 thumbnails are real and working, but I have 450 px place holder images for the other 10.  Will eventually get them all changed, then work on all my lower level Album Sets.  If the corona virus quarantine lasts long enough, will get everything done in a few months.  Has anyone else experimented with this?  At the very least, it may make the surfing experience a bit snappier.

http://www.michaelrichardsphotography.c … l/cruises/

#5 Re: Backlight 2 Support » Custom Thumbnails Sort Order » 2020-05-19 22:42:37

Another question on this subject.  Is there a size limitation for the number of items in the popup menu?  The menu for one of my large album sets has some 600-700 + items by my calculation, while the album set has over 7,000.  So the image I want doesn't show up among the menu items.  I can solve this with custom thumbnails apparently, but I was curios about the size limitation.

#7 Re: Backlight 2 Support » Custom Thumbnails Sort Order » 2020-05-19 16:38:46

Ben wrote:

No nearer a solution. Have you considered setting the cover image using the Backlight admin instead? Let me know if that works for you.

Ben, this will probably create a Homer Simpson "DOH!" moment for me, but I can't seem to figure out how to do this.  Could you point me in the right direction?

#8 Re: Backlight 2 Support » Custom Thumbnails Sort Order » 2020-05-19 15:43:19

Ben wrote:

Hi Mike, thanks for the suggestion. The best approach for now is to set the cover image via the Backlight admin.
I have not heard that this is a widespread concern. Have you found the lack of ordering to be an issue?

Yes.  In the extreme case, I have one album set with 7,237 photos plus there are 59 custom thumbnails. It's very difficult to locate items.

#9 Re: Backlight 2 Support » Custom Thumbnails Sort Order » 2020-05-18 19:16:03

Just an idea.  How about a work-around?  Say, add "auto-select," or something like that, menu item and pick the image that has the word "cover" written in a particular field in the metadata, e.g. Creator, Sublocation, Label.  No help with custom thumbnails, but how about another menu item "custom thumbnails" and select items restricted to custom only.

It would be nice to alphabetize the entire select list, but that's still a tedious and inelegant way to pick the cover image.

#10 Re: Backlight 3 Customization » Redirect to homepage with hero » 2020-05-16 13:28:25

rod barbee wrote:

hi Ben,
I've assigned a cover image. Still no hero image in a page with inserted album.

Same for me.

#11 Backlight 3 Customization » Redirect to homepage with hero » 2020-05-15 22:51:39

richam
Replies: 6

Check on my URL below and you will connect to my homepage without hero.  Click on the "Home" menu item and it will take you to the actual inserted "home gallery" which has a hero image displayed.

I want to redirect my homepage automatically to the "home gallery" page with the hero image.  How can this be easily done?

#12 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-15 16:58:10

Matthew wrote:

I think the lazy-loading throttle has got nothing to do with it. It's just a browser issue.

Agreed.

#13 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-14 19:29:32

The phantom returned.  Now Safari wants to partial load some of the images.  I increased the lazy-load throttle to 100 images.  Tough to get a solution to an intermittent problem.  Will see how it goes.

#14 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-11 01:30:53

Checked it in IOS 9.4 inch iPad.  Got same results, but also with Chrome.  So it seems like IOS problem, not browser.

#15 Re: Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-10 23:11:21

rod barbee wrote:

I still see the issue in Safari iOS with my masthead image.

I reported this as a solution; actually it's a work-around.  Never had the problem with Firefox or Chrome.  I gather Safari interprets loading instructions differently; not sure why.

#16 Backlight 3 Support » Safari Image Loading Problem Solved » 2020-05-10 18:38:58

richam
Replies: 15

Earlier, we were having some BL2 discussions regarding the Safari browser not fully loading images:

http://community.theturninggate.net/vie … p?id=10970

In BL3, I increased the lazy-loading throttle up to 50 images, and the problem disappeared.  Thanks.

#17 Re: Backlight 3 Support » iframe or img error problems solved in BL3? » 2020-05-10 18:12:48

Upgraded to 5.0.1 plugIn.  Forgot how to access and download via BL3 modules.  Much easier, thanks.  Everything working ok.

Now need to update all the albums with Pallet 01 text and replace 250 lines of PHP...

#18 Re: Backlight 3 Support » iframe or img error problems solved in BL3? » 2020-05-10 17:12:19

Ben wrote:

Nothing of consequence has changed in LR publisher between BL2 and BL3.

I re-installed a previous version of the LR plugIn (3.2.1), and it worked ok with BL3.  So indeed nothing consequential happened with the LR plugIn, as you say.  It appears the problem was either somewhere within BL2 itself or Blue Host somewhere.

The new BL3 and associated plugIn (4.0.10) are working fine and stable so far, so I'll drop the issue unless you want to pursue it further.

#19 Re: Backlight 3 Support » iframe or img error problems solved in BL3? » 2020-05-09 01:31:48

Matthew wrote:

Otherwise, I'm not entire sure the specific "problem(s)" you're referring to.

This was discussed extensively in BL2 support, but I'll recap:
I want to embed Google Maps, multiple YouTube and Vimeo Videos, Links, and Images in Pallet 01.
I can implement the various iframe commands via Backlight 2 or 3 directly in a browser -- no problem.
I can implement the various iframe commands n Backlight 2 or 3 using PHP -- no problem.
But in Backlight 2, I got an error every time I tried to implement the commands via the Lightroom PlugIn, which is why I ended up implementing by PHP.

I tested Backlight 3, and found out it's now possible to implement the commands via the Lightroom PlugIn by inserting in the "Pallet 1 Copy" field and publishing.  This would have previously produced an error.  The reasons were never completely sorted out before, but the problem seems to vanish in BL3.  We may have had a Blue Host problem solved with an upgrade unrelated to BL3, I don't know.

I duplicated an album to test it out.  Here are both versions:

Original using PHP

http://michaelrichardsphotography.com/g … mausoleum/

Test album using commands in "Pallet 1 Copy" and published with Lightroom PlugIn

http://michaelrichardsphotography.com/g … leum-test/

I would like to know if anyone has any information on what happened, either in BL3, Blue Host, or whatever the source problem was.  I'd like to implement via Lightroom PlugIn all through the site, but hesitate unless I'm confident it will be stable.

Any light that could be shed on this would be appreciated.

#20 Backlight 3 Support » iframe or img error problems solved in BL3? » 2020-05-07 19:39:17

richam
Replies: 6

In BL2, I had difficulty implementing iframe and img tags via Lightroom plugin, and resorted to using PHP:

http://community.theturninggate.net/vie … p?id=10862

I tested an album in BL3 by inserting sample img and iframe elements in the Main Copy section of the Page Content within the Lightroom plugin.  The test samples worked fine. Can we assume that the original problem within BL2 has been solved?

#21 Re: Backlight 2 Support » Google Search Console » 2020-03-24 17:04:57

Matthew, Here's the whole text of the Google Email:

Videos issues detected on http://www.michaelrichardsphotography.com/

To the owner of http://www.michaelrichardsphotography.com/:

Search Console has identified that your site is affected by 4 Videos issues:

Top Errors

Errors can prevent your page or feature from appearing in Search results. The following errors were found on your site:

Missing field "description"

Missing field "uploadDate"

Missing field "thumbnailUrl"

Missing field "name"

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

#22 Backlight 2 Support » Google Search Console » 2020-03-22 14:15:38

richam
Replies: 5

I got the following message from Google Search Console.  Is there anything that could/should be done about it?  How would I go about making the corrections if I decided to do so?

Errors can prevent your page or feature from appearing in Search results. The following errors were found on your site:

Missing field "description"

Missing field "uploadDate"

Missing field "thumbnailUrl"

Missing field "name"

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

#23 Re: Backlight 2 Support » Safari Partially loads images » 2020-01-08 23:58:31

I surfed around the Apple Safari support pages and found others are having similar problems.  One solution suggested using different DNS servers -- 208.67.222.222 and 208.67.220.220.  I did this, restarted, cleared all history in Safari, and now it seems to be working better, but not 100%.

#24 Backlight 2 Support » Safari Partially loads images » 2020-01-08 23:02:26

richam
Replies: 3

Probably a setup problem, but can't seem to figure it out.  On pages with many images, Firefix and Chrome load normally.  But Safari often loads only a partial of some images.  In Safari, clearing history and forcing reload may fix some of the images, but others show up broken.  I'm using BlueHost with server cache turned off.  Tried disabling php and css in the page template -- no help.  Anyone run across this before?

#25 Re: Backlight 2 Support » Error in Lightroom Publisher » 2019-12-31 17:55:17

Pat on the back for Ben and Matthew for the 4.0.10 plugin.  Works OK now.

Board footer

Powered by FluxBB