Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2019-04-28 12:52:06

eveall
Member
Registered: 2013-01-07
Posts: 105

Publisher & CRG not working after migration

Hi I'm hoping you can help me.

Recently my site was migrated to a new server by my hosting provider.  Since then, i have been unable to access previous client response galleries--they return a white screen.

I tried to look at the Publisher API settings, thinking it might be a problem there, but when i check the API there i get a message: Error reading function (Code 500)

When i go to TTG-BE and attempt to access the publisher settings, i get a screen with the following message:
Fatal error: Class 'DOMDocument' not found in .../public_html/ttg-be/framework/lib/XML2Array.php on line 33

Any other thoughts on what I could do?

Thanks,
Steve

Offline

#2 2019-04-28 14:32:03

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,653
Website

Re: Publisher & CRG not working after migration

Have you tried re-uploading ttg-be?
Is this with the same host?
We’re you using phplugins?
If so, has the server path to phplugins changed?
Have you asked your host about the problem?
Did they change the php version?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Online

#3 2019-04-28 20:17:45

eveall
Member
Registered: 2013-01-07
Posts: 105

Re: Publisher & CRG not working after migration

rod barbee wrote:

Have you tried re-uploading ttg-be?

Not yet, I can't seem to access my previous orders or access the customer page.  I don't get any emails for changing password or previous purchases.  I tried clicking on the links from previous orders and that takes me to a Order Error page.

rod barbee wrote:

Is this with the same host?

Yes. Same host.

rod barbee wrote:

We’re you using phplugins?
If so, has the server path to phplugins changed?

I don't think I was using php plugins, but I'm not sure.  I've kind of set it and forget it.  How can i check this?  Where do I find where the path to the phplugins is?  The server has changed names, but the website location is the same.

rod barbee wrote:

Have you asked your host about the problem?
Did they change the php version?

Initially after migration, they changed the php version so the entire site was down.  They switched it back to 5.6 and the main site worked fine, i just never checked the TTG portion of the site. 
Then more recently, when i realized this issue, I contacted them about this, the person tried some things which ended up knocking down the entire website.

Offline

#4 2019-04-29 00:00:45

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,653
Website

Re: Publisher & CRG not working after migration

If you can’t access your old order, send an email to Amato via the contact form on the Support Page.

Here are details about phplugins, see if any of this is familiar: http://ce4.theturninggate.net/docs/doku … _phplugins

For the rest, Ben may need to look into it. I suggest sending him an email with a link to this topic as well as ttg-be Admin and FTP credentials so he can look into that’s going on with the server.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Online

#5 2019-04-29 11:54:50

eveall
Member
Registered: 2013-01-07
Posts: 105

Re: Publisher & CRG not working after migration

Thanks Rod, i've done both of your recommendations, hopefully we can figure something out.

Steve

Offline

Board footer

Powered by FluxBB