Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#26 2018-09-20 03:41:11

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,390
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

I meant that I loaded your theme into my own Wordpress installation, and it worked. Can't say for certain, but seems like something else might be a problem.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#27 2018-09-20 08:06:23

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 334
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Is it conceivable that a plugin like, say, Wordfence, might be clobbering the site? I bring that up because I encountered a problem with Wordfence destroying the ability to setup cloned Wordpress sites.

On that assumption I disabled them all. Problem persists

Last edited by markh (2018-09-20 08:54:09)

Offline

#28 2018-09-20 08:57:50

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 14,830
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Is any caching that your site might be running turned off?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Online

#29 2018-09-20 09:08:17

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,390
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Like I said, perhaps send me your FTP details so that I can take a look? Backlight admin credentials might also be helpful.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#30 2018-09-20 20:40:32

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 334
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

I've created at ftp acct for you allowing access to the test blog. But when I try it I get a blank file listing. Thought I knew how to setup  ftp accounts in cpanel but apparently I'm missing a step or steps. Will email you the logon. Maybe it works from your end.

Offline

#31 2018-09-21 20:40:43

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 334
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Resolved. The issue with Wordpress showing no content after updating to Backlight2 has been resolved for the test site https://blog.photophart.com/testblog . The fix should have been a bit more intuitively obvious. It wasn't. A reinstallation of Wordpress from within WP admin was the first step to the solution. I then went to the posts, edited the very first post, made no changes and clicked update. All subsequent posts then appeared on the test site. Sidebars as well.
A problem still exists with PHPlugins not appearing on the home page. PHPlugins does appear to be active on other pages in the blog such as galleries and search.
Worth a try if you're seeing this on your site.

mark

P.S. Many thanks to Matt for going above and beyond on this one. A rare event in today's world.

Last edited by markh (2018-09-21 20:43:43)

Offline

#32 2018-09-22 20:35:09

Sven
Member
Registered: 2016-01-01
Posts: 26

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Ben wrote:
Sven wrote:

When I activate the new custom php file the blog side is blank and I get a php error in wordpress

PHP Fatal error:  Class 'URLHelper' not found in /home4/.../public_html/backlight/modules/module-designer/application/helpers/APHPlugins.php on line 27

Hi Sven, you've found a bug.  The PHPlugins have a dependency on our URL helper, but that URL helper isn't available in Wordpress.  I've come up with a fix, that will be included in the next maintenance update.

Update installed and bug has disappeared - many thanks!

Offline

#33 2018-09-23 04:40:40

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,390
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Thanks, Mark. Glad to hear you were able to find a solution. Strange issue, though. I guess there was something amiss with the Wordpress installation? This has been one the head-scratchier issues I've seen with Wordpress, and I think I'm still scratching my head as to what caused it in the first place.

PHPlugins should be working in themes with the latest updates. Check Admin => Backlight Modules to ensure you're on the latest.

If still not showing on the Home page, then what's different about the Home page, as compared to other pages that are working?


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#34 2018-09-23 19:50:08

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 334
Website

Re: Upgrade to BL2 on my blog didn't go as well as my regular sites

Live blog at https://blog.photophart.com has been successfully updated to BL2. However I had to reinstall Wordpress from within WP admin on the site after the BL2 update  just as with my test site. Without reinstalling Wordpress the blog displayed NO content. Latest updates to BL2 appear to have made PHPlugins functional again. Thanks.
Regards, mark

Offline

Board footer

Powered by FluxBB