Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2017-07-12 03:43:30

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

https

In order to use an SSL certificate on my website, I have to serve all content as https, which requires that the http:// links be changed to https:// .  So where do I find those links, please? 

Thanks,
Randy Hoffner

Offline

#2 2017-07-12 03:50:36

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

Guessing it would be in .htaccess

R

Offline

#3 2017-07-12 04:02:23

charlie.choc
Member
From: Marietta, GA
Registered: 2014-01-09
Posts: 359
Website

Re: https

This code will work in .htaccess inside the <IfModule mod_rewrite.c> section:

    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

You also need to change the links in your Backlight settings (company URL, site URL, wordpress ...).

I can't remember if I had to change anything on the uploaded images, but they contain URL's too.

Last edited by charlie.choc (2017-07-12 04:05:07)

Offline

#4 2017-07-12 04:21:15

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

Thanks, Charlie.  Great help!

Randy

Offline

#5 2017-07-12 04:36:47

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

Yes!  That worked nicely.  Thanks again.

Randy

Offline

#6 2017-07-12 09:25:56

jherman
Member
From: Kingsport, TN USA
Registered: 2012-12-09
Posts: 92
Website

Re: https

You may also find help with the discussion from last December where we had some minor issues particularly with FotoMoto.
http://community.theturninggate.net/vie … hp?id=7335

Last edited by jherman (2017-07-12 09:26:13)


User with too little time but coding is therapeutic.

Offline

#7 2017-07-12 12:03:51

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

Thanks.  My big problem now seems to be how to FTP to site.

Offline

#8 2017-07-12 13:22:45

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

Nevermind.  Figured that one out.

Offline

#9 2018-05-18 22:04:35

Markus
Member
From: Witten - Germany
Registered: 2012-10-06
Posts: 147
Website

Re: https

Hello from Germany,

due to the new DSGVO in the EU and Germany I also have to change my website to HTTPS. But I want to try that first on the test page and then update to Pangolin. https://backlight.der-canonier.de/

At my provider all-inkl the SSL encryption is active on my test page, I already changed the path in Company URL and Site URL.
I added the code of Charlie in the.htaccess (where exactly must the code snippet be inserted?)
However, I get an error message and can then no longer access the page and also not the admin area of Backlight.
That's why I took the code out for now.

If I check via Safari with the Inspector, I can see that the page runs on https, but the identity plate still runs on http. Where can I change this to https?
And when I look with the Inspector at "Resources", I find many paths with http (Slideshow, Menu-Item, Auto-Refresh etc.)

They all have to be changed to HTTPS, but how can I do that?

Greetings, Markus

Offline

#10 2018-05-19 00:45:49

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,205
Website

Re: https

this thread mentions the masthead/identity plate image: http://community.theturninggate.net/vie … hp?id=7335
as well as other suggestions such at clearing your template cache.

I'm not positive which .htaccess file needs to be modified, the .htaccess in the root or the .htaccess for albums.
(The one for albums can be modified in Backlight > Settings. Scroll to the bottom and click on Show Advanced Settings.
There's more info you can see by hovering over the info icon.)

Hopefully, someone who's gone through the process can chime in on which .htaccess file they modified.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#11 2018-05-19 02:49:56

randyhoffner
Member
Registered: 2017-07-01
Posts: 69

Re: https

It's been a while, so I don't remember the particulars, but the code Charlie Mentions is in the root .htaccess file.  Have to modify it with a code editor.  It is in the section Charlie said, and I don't recall how I determined where within the section to put it, but it is on lines 45 and 46 of the file, if that is any help.

Offline

#12 2018-05-19 02:56:09

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,205
Website

Re: https

That should help. Thanks Randy.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#13 2018-05-19 03:04:28

dussel
Member
From: OWL / Germany
Registered: 2013-05-27
Posts: 58
Website

Re: https

Markus wrote:

Hello from Germany,

(where exactly must the code snippet be inserted?)

Hello Markus,
as far as i know you have to add that code in the first lines of the .htaccess in the root directory.
hth

Rolf


https://www.rl-foto.de Due to the DSGVO in Europe offline yet

Offline

#14 2018-05-19 20:23:10

Markus
Member
From: Witten - Germany
Registered: 2012-10-06
Posts: 147
Website

Re: https

dussel wrote:

Hello Markus,
as far as i know you have to add that code in the first lines of the .htaccess in the root directory.
hth

Rolf

Hi Rolf,
thanks for your tip, that seems to work with my new testsite.

The old test page has too many links with references to HTTP (css, menu set etc.), where I don't know where I can change them.

The Set menu, for example, are only specified relatively, but are included in the source code with http.

Offline

#15 2018-06-29 02:42:12

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 304
Website

Re: https

Hi, my provider is one.com.

I must not edit .htaccess file with the code to forward the website from http to https.

Rainer

Offline

#16 2018-06-29 03:40:24

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 1,087
Website

Re: https

Hi Rainer,

When I enabled https, I only added following code at the beginning of my .htaccess file in the root directory of my site:

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

This works with 1and1.com.


Daniel Leu | Photography   
DanielLeu.com

Offline

#17 2018-07-02 03:03:34

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 304
Website

Re: https

I don't need it with one.com. Because there comes an error message - to much redirection.
Https on my website works fine, since I enabled it in my control center.

Rainer

Edit:

You are right with 1and1. I have set the same code in .htaccess like you for another website of a friend. Only with this code the website works with https.

Rainer

Last edited by Rainer Goergen (2018-07-02 03:07:35)

Offline

#18 2018-07-02 04:15:32

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 1,087
Website

Re: https

Rainer Goergen wrote:

I don't need it with one.com. Because there comes an error message - to much redirection.
Https on my website works fine, since I enabled it in my control center.

Rainer

Edit:

You are right with 1and1. I have set the same code in .htaccess like you for another website of a friend. Only with this code the website works with https.

Rainer

The reason for the code is to force all connections to https. Your site currently is accessible using http and https. It is strange that you get the too many redirections error.


Daniel Leu | Photography   
DanielLeu.com

Offline

#19 2018-07-02 17:24:05

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 304
Website

Re: https

Thanks, I will test it once more. Maybe the webcache is my problem.

Rainer

Offline

#20 2018-07-03 01:52:16

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,453
Website

Re: https

Perhaps not entirely strange if you examine your source code. For example, on the page view-source:http://www.rainer-goergen.de/galleries/afrika/01-tansania_2007/02-kilimanjaro/.

Many of the links on that page -- to images, for example -- reference their assets using http. Meaning that every image on the page creates a redirect request to the https version of that address. So if you have one-hundred images on a page, then that single page is creating 100+ redirect requests.

Make sure you've set your URLs to their https versions in Backlight's settings, and then clear the template cache. If you're still seeing "http" instead of "https" in your galleries, then we might need to take a look at how we're building those addresses during page render. I've had a brief look at the application code, though, and no potential causes are leaping out at me.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#21 2018-07-03 03:04:13

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 1,087
Website

Re: https

Matthew wrote:

Perhaps not entirely strange if you examine your source code. For example, on the page view-source:http://www.rainer-goergen.de/galleries/afrika/01-tansania_2007/02-kilimanjaro/.

When you change the URL to https://www.rainer-goergen.de/galleries … limanjaro/, the image links are https as well. So I don't think it is a Backlight thing.


Daniel Leu | Photography   
DanielLeu.com

Offline

#22 2018-07-03 06:11:32

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,453
Website

Re: https

In which case, make sure your menus, album sets, etc. are providing links using the https:// protocol. I got to that page by clicking through the site, and arrived with an http://... URL, which -- given your .htaccess rules above -- I believe should have triggered a good many redirect requests.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#23 2018-07-04 19:35:48

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 304
Website

Re: https

I changed the code in .htacces like one.com writes in the FAQ:

RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Now the redirection works without any error message but, if I go to the search page with http:// there is no redirection to https://

http://www.rainer-goergen.de/backlight/search/

Also the found albums and images - there is no redirection to https://

And in the menu bar all links are to http://.

Try a search for - flower -

http://www.rainer-goergen.de/backlight/search/

------

If I go with http://www.rainer-goergen.de to my website, the redirection changes to https://www.rainer-goergen.de.

If I now click on - search - in the menu bar, the redirection changes to https://www.rainer-goergen.de/backlight/search/

------

In Backlight admin I have changed all entries to https:// - but where have I to change it in menus, album sets etc. ?

Rainer

Edit:

The same with my Wordpress test site:

http://www.rainer-goergen.de/blog/

There is no redirection to the https:// site.

In the menu bar now all links are set to https://

Rainer

Last edited by Rainer Goergen (2018-07-04 20:47:39)

Offline

#24 2018-07-06 03:13:15

Rainer Goergen
Member
From: Trier, Germany
Registered: 2016-05-01
Posts: 304
Website

Offline

#25 2018-07-06 05:45:13

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,205
Website

Re: https

Since this is affecting albums, have you tried updating the album .htaccess? (Backlight Advanced Settings)


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

Board footer

Powered by FluxBB