Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2018-02-03 05:43:55

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 497

Gallery error

Still working on this test site: pideja.ca/luc/fr and I have a brain cramp about installing the Gallery (Oeuvres). I get this error: PangolinAlbumSetDataModel::getEmbeddedAlbumId() in PageController.php on line 84

What does this mean?

Offline

#2 2018-02-03 06:55:20

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,976
Website

Re: Gallery error

What steps have you taken in creating your top-level gallery?
It looks to me that there is no folder named “oeuvres” (404 error) and I get a 403 Forbidden when checking for a galleries/ folder.

If you want the top-level folder to be named oeuvres, then you need to create it in the fr/ folder.
You’ll need to point Publisher to that folder.
See the installation docs for more details


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#3 2018-02-03 07:21:29

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 813
Website

Re: Gallery error

Here would be the description on how to create a new top-level gallery: http://community.theturninggate.net/vie … hp?id=6366


Daniel Leu | Photography   
DanielLeu.com

Offline

#4 2018-02-03 09:34:50

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 497

Re: Gallery error

I created a page named "lucfr-oeuvres" in the PAGES section.
I also created a GALLERY SET page named "oeuvres"...
In LR Publisher, I changed the top-level to "oeuvres" and create an ALBUM called "Bestiaire".
The API is good.

If you have time, the credentials for pideja.ca/luc/fr/backlight"are:

admin    lucfr
guest    touriste

Offline

#5 2018-02-03 09:53:21

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,976
Website

Re: Gallery error

Well, in the luc/fr set up you have one top-level gallery and it's named "galleries". So that's the only folder you can publish to for this site.
There is an album in it named Bestiaire but trying to look at that just leads to a 404 Page Not Found.

lucfr-top-level.jpg

There seems to be an album set here: http://pideja.ca/luc/fr/oeuvres/ but I've no idea how you got it there. Might help to see a screen shot of your Publisher set up in Lightroom.

I created a page named "lucfr-oeuvres" in the PAGES section.

Not in the luc/fr installation. There's no page by that name. There is a page template by that name however.

I also created a GALLERY SET page named "oeuvres"...

You've created a album set template named oeuvres. There is no page by that name. I'm guessing you want this template to be applied to your top level gallery?

If you want a folder named "ouevres" as your top level galleries folder, the go in via FTP and change the name of the galleries folder or create a new folder..

It seems like you're confusing the differences between page templates and pages.
You need to create pages in the Designer > Pages section. When you create a page, then assign a page template to it.
http://ttg-tips-and-tricks.barbeephoto. … templates/


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#6 2018-02-11 01:10:34

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 497

Re: Gallery error

I've got the link to "oeuvres" to work. Changed the name "gallery" in Top-level Galleries to "oeuvres".
I believe that the page template "lucfr-oeuvres" being based on the "lucfr-acceuil" should display the same layout as the other pages (Acceuil, Biographie, and Contact).
For some reason, the "oeuvre" page displays without navigation much like in the rest of the site.
Also, I can't get the thumbnails to have a transparent background (there is only one, for now). For now it's black, but I would rather see the background around the thumbnail, possibly with a border (black). Also, how can I control the size of the thumbnail and/or the caption below it?
As for the album itself (bestiaire) it looks good using the Masonry type and the single-image display. But the overall design of the page fails to display the navigation, same as the album-set "oeuvres"

Here is a screenshot of the ftp setup : FluxBB bbcode test
and a screenshot of the settings the "oeuvres" in luc/fr :          FluxBB bbcode test

Last edited by pideja (2018-02-11 01:30:28)

Offline

#7 2018-02-11 02:52:41

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,976
Website

Re: Gallery error

For some reason, the "oeuvre" page displays without navigation much like in the rest of the site.

the likely reason you're not seeing navigation on the Oeuvres page is that the album set being used for that page isn't using a page template with navigation enabled on the desktop.

I'd take a look but the guest credentials (above) no longer work.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#8 2018-02-11 03:06:11

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,976
Website

Re: Gallery error

Also, I can't get the thumbnails to have a transparent background (there is only one, for now). For now it's black, but I would rather see the background around the thumbnail, possibly with a border (black).

In the album set template, set the background to transparent using the transparency slider in the color picker.

Also, how can I control the size of the thumbnail and/or the caption below it?

Actual thumbnail size is controlled by the albums contained within the album set.
In the album set you can change number of columns, max thumbnail width, aspect ratio, and gallery max-width. All these will have an effect to varying degrees.
You can control the length of the character limit in the description area. Otherwise, what size changes are you looking for?

As for the album itself (bestiaire) it looks good using the Masonry type and the single-image display. But the overall design of the page fails to display the navigation, same as the album-set "oeuvres"

This, again, is a function of the page template's navigation settings.

Since this is getting way off the original topic, if you have other issues, can you start new topics for them. Be sure to include links. (As well as Backlight access credentials if you want someone to take a look under the hood.)


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

Board footer

Powered by FluxBB