Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2017-09-15 00:15:39

kishw
Member
Registered: 2014-09-23
Posts: 38

Some Galleries Returning Error in web browser

Hi,

A few of the galleries on my website www.kishwphotos.co.uk/private_galleries are returning an error message which I don't understand as they used to work and I haven't updated or changed them for a while.

The error message is :
Function name must be a string|#0 /home/kishw584/public_html/ttg-be/framework/lib/Parsedown.php(931): Parsedown->element(Array) #1 /home/kishw584/public_html/ttg-be/framework/lib/Parsedown.php(257): Parsedown->elements(Array) #2 /home/kishw584/public_html/ttg-be/framework/lib/Parsedown.php(48): Parsedown->lines(Array) #3 /home/kishw584/public_html/ttg-be/publisher/application/models/Album.php(962): Parsedown->text('Click on any Im...') #4 /home/kishw584/public_html/ttg-be/publisher/application/models/Album.php(89): Album->parsedown('Click on any Im...') #5 /home/kishw584/public_html/ttg-be/templates/gallery/captioned slide show template/template_index.php(372): Album->getPageCopy() #6 /home/kishw584/public_html/ttg-be/publisher/application/controllers/GalleryController.php(328): include_once('/home/kishw584/...') #7 /home/kishw584/public_html/ttg-be/framework/controllers/Controller.php(41): GalleryController->gallery('6205', 'index', '') #8 /home/kishw584/public_html/ttg-be/framework/Framework.php(124): Controller->dispatch(Array) #9 /home/kishw584/public_html/private_galleries/hanwell_carnival_fete/lib.php(48): Framework->route() #10 /home/kishw584/public_html/private_galleries/hanwell_carnival_fete/index.php(4): route(Array) #11 {main}|URL: /private_galleries/hanwell_carnival_fete/index.php

I have tried to upload the galleries but still get this message when clicking on the tumbnail to access them....I am unable to tell if this issue is with the gallery index page or the specific galleries or which LR plugin I need to look at to try and correct it
the galleries that aren't working are
/hanwell_carnival_1/
/hanwell_carnival_fete/
/norwood_green_village_day/
/palace-to-palace/

Your help in resolving this issue would be most appreciated.
Thanks
Kish Woolmore
kishwphotos.co.uk
London

Offline

#2 2017-09-15 00:32:10

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,237
Website

Re: Some Galleries Returning Error in web browser

The first thing to try is updating your version of CE4 Gallery. You're using version 6.1.0, the last version is 6.1.10
http://ce4.theturninggate.net/docs/doku … _changelog

Also, your template name contains spaces. This can cause problems in accessing assets. File and folder names on the web should contain only letters, numbers, underscores, or dashes. No spaces or special characters.

the albums that are working are using a more recent version of CE4 Gallery (6.1.5) and the template names contain no spaces.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#3 2017-09-15 00:59:43

kishw
Member
Registered: 2014-09-23
Posts: 38

Re: Some Galleries Returning Error in web browser

Thanks for the quick response, however I am somewhat confused by the answer:

In simple terms I need to update to version 6.1.10 of CE4 Gallery
then do I need to republish all my galleries with that ? do I need to change anything in the galleries in LR to be able to get it to upload new versions to the website ?

I am confused by template name contains spaces - I cannot see where or how to change this as galleries I have don't have spaces in the names ? Would this also cause a problem if the particular templates aren't even used for any of the galleries ?

I also have an issue in trying to access password protected galleries using the master password, it doesn't appear to work or I have forgotten it - is it possible to find the password or reset it without having to upload the whole website from scratch...

Again I thank you for your support and help in resolving these issues.
Regards
Kish Woolmore

Offline

#4 2017-09-15 01:08:51

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,237
Website

Re: Some Galleries Returning Error in web browser

update the plug-in. The export and upload the templates to ttg-be/templates/gallery/
Make sure you don't use any spaces in the template names.
In Publisher, edit each album so that they use the new template (the one that contains no spaces in the name)

I am confused by template name contains spaces - I cannot see where or how to change this as galleries I have don't have spaces in the names ? Would this also cause a problem if the particular templates aren't even used for any of the galleries ?

For the albums that are throwing the error, the gallery that you exported and uploaded to ttg-be/templates/gallery/ contains spaces in the folder name.
Since you should update the templates using the latest version of CE4 Gallery, just name them the same but use dashes or underscores instead of the spaces.

I also have an issue in trying to access password protected galleries using the master password, it doesn't appear to work or I have forgotten it - is it possible to find the password or reset it without having to upload the whole website from scratch...

This could be related to the other problem. So update the template first and see if the problems go away. I noticed that at least one of the password protected albums uses a template that has spaces in its name.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#5 2017-09-15 02:14:44

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 4,970
Website

Re: Some Galleries Returning Error in web browser

It sounds like your host may have changed your PHP version, which is causing the Parsedown script to break. See Ben's reply on this other thread. http://community.theturninggate.net/vie … 500#p46500


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#6 2017-09-15 18:39:05

kishw
Member
Registered: 2014-09-23
Posts: 38

Re: Some Galleries Returning Error in web browser

Just to keep you updated - I downloaded the latest ttg-be and uploaded the new version of  parsedown.php to my web server and the galleries are now accessible. But the ones that are password protected only seem to respond to the user password assigned they do not work with the master password or guest password ?

Sorry been a while since last updated/exported templates can you send me link to correct documentation showing how ?

Is the user passwords set in ttg-be/admin the same as the master password ?

I notice that my ttg-be shows as v 2.03 and the latest download is 2.05a - should I install this as is the file says NOT TO if website is working ?

Thanks for your patience and help.
Kish Woolmore

Offline

#7 2017-09-15 21:14:40

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,237
Website

Re: Some Galleries Returning Error in web browser

Unless you're using Publisher, gallery master passwords are set in the template. It's under the Output Settings control pane in the CE4 plugin.

If using Publisher, the master password is set in ttg-be under Publisher > Settings.

CE4 documentation can be accessed from the CE4 link on the Support page: http://theturninggate.net/support/

you should probably update TTG-BE to 2.0.5 as well, as there were other updates to TTG-BE 2.0.4.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

Board footer

Powered by FluxBB