Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2017-08-05 03:49:01

seafizzer
Member
Registered: 2016-02-04
Posts: 16

Update: Individual Albums show ok BUT top level galleries throw errors

My 1.1 Backlight install was just updated to 1.2.2.  It has pages, (no cart,client response or wordpress etc).
I put the following old directories into the new 1.2.2 modules directory in order to keep the old albums intact:
-modules/standard album
-modules/standard album set
-modules/page

The good news: It is possible to get to the old albums, AND to create and access new 1.2.2 albums.
The bad news: index pages for top-level indexes are broken, throwing the following error messages:
___________________

"Something went wrong
The album with id 1 could not be found in GalleryDelegate.php on line 114"


Above is error when going to top-level album index page that was created with Backlight 1.1

___________________


"Something went wrong

Unexpected error: Undefined variable: breadcrumbs in Album.php on line 315

Please report error at http://community.theturninggate.net"


above is error when going to top-level index page created with new Backlight 1.2.2



How to fix?  thank you!

Offline

#2 2017-08-05 06:38:48

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,060
Website

Re: Update: Individual Albums show ok BUT top level galleries throw errors

can you post a link to your site so Ben and Matt will have something to look at?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#3 2017-08-05 06:47:50

seafizzer
Member
Registered: 2016-02-04
Posts: 16

Re: Update: Individual Albums show ok BUT top level galleries throw errors

HI Rod, thanks for response

, I ftp'd the 'publisher' directory, (some how was not uploaded originally) and am now able to get the 1.2.2 top-level index, but the 1.1 album index still throws this  error:

'Something went wrong
The album with id 1 could not be found in GalleryDelegate.php on line 114'

http://session.photogenerations.com/galleries/ .  is 1.1 top level
http://session.photogenerations.com/2017/ .  is 1.2.2 top level

Colleen

Offline

#4 2017-08-05 06:52:24

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,060
Website

Re: Update: Individual Albums show ok BUT top level galleries throw errors

After you uploaded the current publisher/ directory, did you log in to Backlight and visit the Publisher section so that the database would update?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#5 2017-08-08 08:34:38

seafizzer
Member
Registered: 2016-02-04
Posts: 16

Re: Update: Individual Albums show ok BUT top level galleries throw errors

HI Rod,
Yes I did update the Publisher.  Now the 1.2.2 top-level page loads fine, but the 1.1 top-level (galleries link above) throws error:

'The album with id 1 could not be found in GalleryDelegate.php on line 114'

Offline

#6 2017-08-08 14:37:30

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,193

Re: Update: Individual Albums show ok BUT top level galleries throw errors

I'm not sure how that would have come about.  Can you email me with a Backlight admin login so that I can look into this?

Offline

Board footer

Powered by FluxBB