Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-11-16 14:39:49

Timelessimages
Member
Registered: 2016-04-19
Posts: 49

Help please.. I messed up all my galleries..

HI there,
I inadvertently deleted the lrgalleries folder that contained ALL my Galleries, Smart Albums and albums sets.
These were all published through lightroom.

When I go to republish them, it tells me the folder where each gallery was no longer exists. I have created the lrgalleries folder again and given it 755 permissions. I still get the error.

How do I recover from this???

Offline

#2 2016-11-16 14:43:29

Timelessimages
Member
Registered: 2016-04-19
Posts: 49

Re: Help please.. I messed up all my galleries..

Offline

#3 2016-11-16 14:51:25

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,061

Re: Help please.. I messed up all my galleries..

That's no good.  Try editing each album in Lightroom, from the highest most to those further down the tree of album sets (if you have any).  By edit, I just mean double-clicking each album or set (right-clicking then edit for each set -- i wish double clicking worked for these) and click save.  After doing so, try re-publishing the photos in those albums as you go.

Offline

#4 2016-11-16 14:58:11

Timelessimages
Member
Registered: 2016-04-19
Posts: 49

Re: Help please.. I messed up all my galleries..

thanks Ben, will give it a try. there is no save option when you edit an album or set, just Cancel and Edit at the bottom. I'm guessing its Edit as Cancel dont sound right..

Offline

#5 2016-11-16 15:07:41

Timelessimages
Member
Registered: 2016-04-19
Posts: 49

Re: Help please.. I messed up all my galleries..

Done that now the gallery shows:


Warning: require_once(lib.php): failed to open stream: No such file or directory in /home/timele32/public_html/lrgalleries/client-gallery-sneak-peek/index.php on line 3

Fatal error: require_once(): Failed opening required 'lib.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/timele32/public_html/lrgalleries/client-gallery-sneak-peek/index.php on line 3

Offline

#6 2016-11-16 15:38:36

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,061

Re: Help please.. I messed up all my galleries..

Hmm. Can you login into the Publisher admin then click on the link 'update album files' and see whether that fixes the gallery?

Offline

#7 2016-11-16 15:50:28

Timelessimages
Member
Registered: 2016-04-19
Posts: 49

Re: Help please.. I messed up all my galleries..

Thanks Ben, found a missing php file which resolved the error message. Now its starting to look better, Will be ok from here I think. smile

Offline

#8 2016-11-16 16:42:03

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,061

Re: Help please.. I messed up all my galleries..

I'm glad to hear. Please post back if other issues arise.

Offline

Board footer

Powered by FluxBB