Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-08-04 11:42:21

hulsebos58
Member
Registered: 2012-12-09
Posts: 53

CE4 Contact Page not sending message

My contact page was working properly. But I just had a customer tell me he tried twice to get to me through my contact page, and I got no message. I did a test, and no message. I have Mail Send Type set as Mail in TTG-BE. My email address is set the same in TTG-BE and Bluehost. It's a gmail address. [deleted by mod] Help, I am missing important messages.
www.martyhulsebos.com

Last edited by hulsebos58 (2016-08-04 11:44:01)

Offline

#2 2016-08-04 11:47:56

hulsebos58
Member
Registered: 2012-12-09
Posts: 53

Re: CE4 Contact Page not sending message

It's now working. No rhyme or reason. But my other domain is still not working:
www.natureimagesforhealthcare.com

Last edited by hulsebos58 (2016-08-04 11:54:10)

Offline

#3 2016-08-04 12:14:07

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,298

Re: CE4 Contact Page not sending message

Bluehost will only reliably send out emails if sending as an email address that Bluehost knows about.
To make this happen, make sure that the email address belongs to a domain you have hosted through Bluehost.  For example, yourname@natureimagesforhealthcare.com.

You then need to set up that email address in Bluehost's control panel.  That doesn't mean that Bluehost needs to manage the email account, just that you have added an account with that address through the control panel.

Once those steps are taken, Bluehost should send the email correctly as from the email address you have set, rather than from a system email address that doesn't correspond to your domain.  Such emails are much more likely to make it through the various spam mechanisms and into the recipient's email.

Online

#4 2016-08-04 20:53:03

hulsebos58
Member
Registered: 2012-12-09
Posts: 53

Re: CE4 Contact Page not sending message

So in TTG-BE, should I use myname@natureimagesforhealthcare.com for both the Site Email and Vendor Email? Or can I use it for just one of them? (which one?)...the other one being my gmail address.

Last edited by hulsebos58 (2016-08-04 20:53:47)

Offline

#5 2016-08-04 21:15:45

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,298

Re: CE4 Contact Page not sending message

Vendor Email.  That's what's used as the from address, which is what Bluehost's servers are interested in.

Online

#6 2016-08-04 21:21:10

hulsebos58
Member
Registered: 2012-12-09
Posts: 53

Re: CE4 Contact Page not sending message

Thanks. Now works if I change Vendor Email to myname@natureimagesforhealthcare.com but I have to keep Site Email as my regular email. Otherwise it didn't work. (BTW, I do have myname@natureimagesforhealthcare.com forwarded to my regular email address).

Last edited by hulsebos58 (2016-08-04 21:21:38)

Offline

#7 2016-08-25 06:13:07

hulsebos58
Member
Registered: 2012-12-09
Posts: 53

Re: CE4 Contact Page not sending message

It's not working again on martyhulsebos.com. It is working on natureimagesforhealthcare.com. Nothing was changed. I just tested it for the first time after it got fixed weeks ago.
Help, I need for my customer to be able to reliably get ahold of me.

Offline

Board footer

Powered by FluxBB