Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2018-09-13 22:31:13

mblanchette1
Member
From: Bedford, NH
Registered: 2012-10-15
Posts: 105
Website

Page Addresses

First of all, congratulations to the team for an excellent upgrade. I was able to upgrade my test site in less than a day, compared with previous upgrades that required redoing templates, etc. With the exception of my blog (last to do), my test site is now fully functional...except for one nagging issue.

This is a weird problem. Backlight 2 seems to address all its pages using the format "/?page=about" rather than a fixed address like "/about/". This all works fine until you go to a gallery index or gallery. One you've been in a gallery, the addresses switch to the old fixed format. At that point, clicking on any other menu causes an error since the pages are no longer recognized.

It's easier to see it than describe it. You'll find my test site here http://www.mabtesting.dreamhosters.com/. Click on any menu other than a gallery and things work as expected. Now click on Galleries or any individual gallery in the menu, and then try to press Home or any other menu item. Addressing fails to find the page with message 404 NOT FOUND.

At first, I thought it might be an upgrade issue with existing galleries, so I deleted them all from my test site and re-uploaded them. That apparently had nothing to do with the problem since it continues to occur.

I'm lost to figure out why this is happening. Any ideas? It's the only issue I've found so far with this great release.

Last edited by mblanchette1 (2018-09-13 22:38:38)

Offline

#2 2018-09-14 00:02:55

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 14,830
Website

Re: Page Addresses

Hi Mike,


I can't duplicate this on my test site. My guess is that Ben is going to want to take a look at the back end. I suggest emailing him Backlight admin login credentials.

Are the .htaccess files in the right places?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#3 2018-09-14 06:19:57

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,709

Re: Page Addresses

It looks like the .htaccess file at the top of your site is missing.  Backlight 2 (and Backlight) uses the .htaccess file at the location being browsed to determine whether URL rewriting is available.  That's why under galleries, which would have working .htaccess files, the links are set to the format of /about/.  However with the missing .htaccess at the top of your site, the links in the format of /about/ aren't able to be processed.

Offline

#4 2018-09-14 20:39:10

mblanchette1
Member
From: Bedford, NH
Registered: 2012-10-15
Posts: 105
Website

Re: Page Addresses

I thought I had copied the .htaccess file but it certainly wasn't there. Must have copied it to the wrong place. I copied it and everything now works. Sorry about that but thanks for the help.

Offline

#5 2018-09-14 21:30:28

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,709

Re: Page Addresses

No worries.  I'm glad you solved it.  It makes it tricky having a disconnect between whether a certain part of the site thinks .htaccess is supported, and another part that doesn't support it being unable to process a link coming from the site that thinks it's supported..

Offline

#6 2018-09-15 06:48:08

mblanchette1
Member
From: Bedford, NH
Registered: 2012-10-15
Posts: 105
Website

Re: Page Addresses

Everything on my test site is working exactly like the prior Backlight 1 site. Thanks for the help.

Last edited by mblanchette1 (2018-09-15 06:48:34)

Offline

Board footer

Powered by FluxBB