Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2018-02-11 21:56:40

dakota20
Member
Registered: 2013-02-10
Posts: 11

New site with nasty problem on iPhone und iPad

Hi

I converted my foto website from CE2 to Backlight 123/4 just last week. Everything works fine on the desktop (Mac with Safari) but on my iPhone and also on the iPad there are some nasty problems. The site loads ok but more often than not the masthead and the picture on the home/info/about page does not load - space simply empty. Then, when I touch the menubar the pictures suddenly appear - as if they had been hidden. Checked everything but found nothing.

http://foto.descan.com

guest pw is descan999

Help and feedback welcome.

Greetings from Switzerland, Peter

Offline

#2 2018-02-12 00:09:59

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,103
Website

Re: New site with nasty problem on iPhone und iPad

your masthead image is pretty big, 2000px and 1300Kb. That made it slow to load on my laptop.
My iPad loaded it (slowly) without me needing to do anything but wait.

it looks like the content of your page is contained to something like maybe 1200px? But I can't tell. Guest Viewer access only lets us see so much. To see what's going on in template settings we'd need Guest Updater access.

But try reducing the size of your masthead image and don't use anything larger than what's needed.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#3 2018-02-12 01:49:53

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Thanks Rod for your reply on a Sunday afternoon

Yes, my pics are pretty big - I don't know what made me go with png. Now I made the masthead smaller and all page pics are now jpgs, exported from Illustrator with 60%. none is bigger than 78 kb.
Also changed the guest user.
But, alas, still the same effect on my iPad Pro 10.5 inch. Sometimes the pics load and sometimes not... Desktop is ok.

So, I am back to square one.
???

Greetings Peter

Offline

#4 2018-02-12 02:09:07

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,103
Website

Re: New site with nasty problem on iPhone und iPad

I see what you mean. I sometimes see something similar in my own test site where I'm using an image in the masthead. But a refresh usually brings the image in.
I see it in this set of pages where I'm working on the update for my main site: http://pangolin.barbeephoto.com/galleri … bum-tests/

At first, the upper half of the image shows up. After refreshing the rest appears. Happens so far in Safari and Firefox for iOS

See if you see the same thing happening on that page as is happening on your site.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#5 2018-02-12 03:02:02

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Hi Rod

Yes, I find the same is happening on your site: After following the link (on the iPad) in a new tab the page is displayed ok and full. Then I touch the Palouse album (or another one after starting again) and the masthead space ist simply white. Touching the menubar immediately brings the masthead picture - and the menu on the right side.

Well, from my point of view, this is fortunate since that shows I did nothing very wrong...

Greetings again, Peter

Offline

#6 2018-02-12 03:03:55

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Rod, I forgot to say: this is not consistent: sometimes (more often than not) it is working properly...

P.

Offline

#7 2018-02-12 03:13:05

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,103
Website

Re: New site with nasty problem on iPhone und iPad

This info will give Matt something to go on. I could simply be an iOS quirk too.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#8 2018-02-12 03:25:00

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Hi Rod

I might add - my last message for today - that the same thing happens with Chrome on my iPad Pro. Just thought I might give it a go.

Thank you for your time.

P.

Offline

#9 2018-02-12 17:08:08

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,442
Website

Re: New site with nasty problem on iPhone und iPad

I'm not seeing the issue on my own devices, so not something I can troubleshoot properly. The code looks good to me as well, so nothing obvious or broken therein that I can see.

Could be a combination of large image size and slow or intermittent network connection, or hiccups during file transfer. The recurrence of the issue having replacing the image with a smaller version might be due to your device still pulling the image from the earlier cache; iPhones and iPads, you need to go into Settings => Safari to manually clear the browser cache.

Also not sure what version operating system you're running; Safari has had its share of bugs over the years.

You're implementing the masthead in a way that I have identified as being potentially non-ideal; you might want to check out my tutorial on crafting mastheads in Backlight.
http://theturninggate.net/2017/11/16/ma … -masthead/


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#10 2018-02-12 18:30:37

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Hi Matthew

Thank you for your reply.

well, I cleared the safari cache but that did not help. Same problem on the first call to the foto website on my iPhone 8.
And my wifi is quite stable, I am in direct line of sight to my Netgear router.

And - since Rob mentioned IOS quirks - I tried the same on my wifes iPhone 5 (with iOS 10.3.3) and I did NOT experience any malfunction after a number of tries. Tried also her iPad (with iOS 11.2.5) and find the same problem as with my iPhone 8 and iPad Pro (both with 11.2.5).

On both my Macbook Pro I do not experience the problem. One runs with Maverick (need this because of Adobe CS6 suite) and the other runs High Sierra.

Well, that is all I can say....

But I am going to check out your masthead tutorial. Thank you for pointing this out to me. I will change my implementation accordingly.

Greetings from Switzerland. Peter

Offline

#11 2018-02-12 21:22:17

dakota20
Member
Registered: 2013-02-10
Posts: 11

Re: New site with nasty problem on iPhone und iPad

Hi again

I now modified my masthead according  to the video Matthew pointed me to. I am very happy with this since I find that all is well now. The mastead appears ok on both iPhone and iPad consistently.

http://foto.descan.com/

As far as I am concerned: problem went away, carpe diem.

Thank you for your support.

Peter

Offline

#12 2018-02-12 23:39:30

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 5,442
Website

Re: New site with nasty problem on iPhone und iPad

Awesome. Glad to hear it's working better for you. big_smile


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

Board footer

Powered by FluxBB