Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2017-03-11 05:41:19

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

image on home page not displaying

Trying to upgrade a CE4 site into a Backlight site. Must rebuild everything from scratch, as you know.

First problem: a first HOME page will lead into separate French and English sections of the same site. On this page, there is no masthead or title. Rather, I built a "nameplate" that should display centered and below the navigation that will read FRENCH and ENGLISH, that will be links to these sections.

I put the image path int
the PAGES/HOME page/Page copy/Main copy as <img src="backlight/photos/Nat_ID-Modifier C.S.C.jpg" width="700" class="aligncenter">. This image is already uploaded into backlight.

But the image fails to display. I get the message: Unable to find pageTemplate with ID 77. Try updating the selected template for the application. in EngineFactory.php on line 70 when trying to access the image.

Also, I can't get it to center. And the "company name" always appears.

The CE4 site to be copied:http://www.nathaliemoliavko-visotzky.com/

The Backlight site in question: http://pideja.ca/nat

Offline

#2 2017-03-11 06:04:30

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

first, the image filename may be causing problems. It's got spaces and periods in it.

Where/how did you upload the picture? (if you used the Backlight upload function, then the image source you're trying to use won't work)
your picture is supposed to be in pideja.ca/nat/backlight/photos/Nat_ID-Modifier%20C.S.C.jpg. is this where you uploaded to? is there a photos/ folder inside of your nat/backlight/ folder?

that error implies that a page template is missing. Did you happen to create a page using that template and subsequently delete the template?

on centering the image, it actually is centered in the main column. That page has two columns, with the tray on the left hand side.

When you say the "company name always appears". where are you seeing this? What's it supposed to be?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#3 2017-03-13 03:20:16

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

The HOME page is now set...I changed and simplified the image file name; rather than try to put it as a page content, it's now a masthead; menu items on the top of the page.
It's not a real improvement design wise, but I'm starting by "adapting" the original CE4 site to now be in Backlight. I just hope it works.
Now trying to implement separate but almost identical sections: French & English. Create pages for both languages as pideja.ca/nat/fr/ & pideja.ca/nat/en.

Having a hard time explaining this to Publisher...In menu sets, I created links to both "sides": the French is fr/galleries.php and the English side is en/galleries.php Created an API and indicated the API url path in publisher for each side (fr & en).
But I can't have Publisher accept this. Each section (fr and en) has the backlight, galleries, theater folders and the index.php file.

The goal is to navigate from the home page (which is more or less a portal) to the galleries page (where the album thumbnails will reside. From there, each thumbnail will lead to a video (hence the theater module).

All this managed from Publisher.

Last edited by pideja (2017-03-13 03:46:15)

Offline

#4 2017-03-13 04:03:17

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

When attempting to check authentification, I get this:

An internal error has occurred : JSON.lua:458: JSON.lua:197: can't parse JSON at char 1 of: Backlight is not yet configured.  Please login to Backlight at /backlight/ to continue.

Publisher API URL: http://pideja.ca/nat/fr/backlight/publisher/
              API Key: 4322


guest credentials: guest/guest

Last edited by pideja (2017-03-13 04:05:02)

Offline

#5 2017-03-13 04:26:25

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

Double check that API URL. It goes to a non-existing location.
Do you have Backlight installed in:
pideja.ca/nat/fr/?
That error message implies you don't


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#6 2017-03-13 04:54:14

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

Trying something: on the fr side, I imported the corresponding CE4 from the active site http://nathaliemoliavko-visotzky.com/na … leries.php. Works well as expected.
But the point is to upgrade to Backlight and have Publisher manage/upload the videos with the albums.
Also, I can't find the API Key for this CE4 installation. Anyway to retrieve it?

As for the en side, still trying with Backlight; API URL is pideja.ca/nat/en/backlight/publisher/; there is a Publisher folder at that address; still get same error message.

Could the problem stem from the fact that the en link on the Home page leads to pideja.ca/nat/en/galleries.php ?

Last edited by pideja (2017-03-13 04:58:07)

Offline

#7 2017-03-13 05:00:02

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

are you trying to mix in a CE3 site with Backlight? Above you've got an API url for fr, but on the page link you provided in the previous post, if I click on 'fr' I'm taken to a CE3 based page.

Is Backlight installed in pideja.ca/nat/en/?

can you illustrate the folder structure, I'm having a hard time visualizing what you're trying to do


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#8 2017-03-13 06:33:28

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

I am very sorry for the confusion I have caused.

This is a test site so I am trying things. The structure as of now is as follows:

pideja.ca/nat is a portal leading to  "fr" and a "en" sub-domains;

on the "fr" side, I have imported the CE4 gallery from the current on line site http://nathaliemoliavko-visotzky.com. This has been done to verify if such a thing can be done.

but the "en" side is the backlight upgrade side: the API URL is pideja.ca/nat/en/backlight/publisher I have assigned an  API key and these credentials have been put into Publisher within Lightroom. But they are not accepted, like previously.

Here is a view of the folder structure:folders

This is a view of the structure, once you are into pideja.ca/nat

As you can see, the Publisher folder is within the Backlight folder in the "en" section.

Last edited by pideja (2017-03-13 06:34:58)

Offline

#9 2017-03-13 07:17:29

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

Have you logged in to the en/backlight admin and configured the Publisher settings?
you need to go here and set your api key, etc. http://pideja.ca/nat/en/backlight/admin/

What is the "Theater-104 Folder" in en folder for? Theater needs to be installed in backlight/modules

Is the plan to have separate sites under nat/ ? Are they both going to be Backlight sites?

There's probably an easier way of doing this than installing multiple Backlight installations, depending on what you want the structure to be and how you want to manage it.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#10 2017-03-13 22:22:49

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

I had not realized that every Backlight installation must be configured. The "en" side is now setup. Publisher is happy and I am working on getting the links sorted out.

Yes, the plan is to make this a Backlight upgrade to the existing site built in CE4. So, a Portal(Home)page and two parallel sites to cater to both languages. When leaving the portal, you will go directly to the Galleries where the other links, to the Home, Gallery, Bio and Contact links will be available. It's rather simple and straightforward but until some light starts shining in my brain(!), I'll go with this design.

I read, in a post from 2015 that "I ended up adopting a hybrid of what Rod and I were talking about...one Backlight at the root with all of the new Pages content at the root and liberal use of the responsive grid layout (VERY NICE...MUCH SUCCESS!!! smile )"
Is it something like that you have in mind?

The main motivation for upgrading to Backlight, for this site, is that there are changes regularly and in CE4 there is always a new gallery page to make + the videos have to be inserted manually, thru my ftp client.

Am I wrong in thinking that this whole process of updating the site will be easier and less prone to mistakes in Backlight?

Offline

#11 2017-03-13 23:18:15

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

pideja wrote:

I read, in a post from 2015 that "I ended up adopting a hybrid of what Rod and I were talking about...one Backlight at the root with all of the new Pages content at the root and liberal use of the responsive grid layout (VERY NICE...MUCH SUCCESS!!! smile )"
Is it something like that you have in mind?

Without context (link to the post) I can't comment.

pideja wrote:

Am I wrong in thinking that this whole process of updating the site will be easier and less prone to mistakes in Backlight?

No, you're not. Making design and other changes is much easier and faster in Backlight. Updating albums will be the same as that's all handled in Publisher, just like in CE4.

pideja wrote:

Yes, the plan is to make this a Backlight upgrade to the existing site built in CE4. So, a Portal(Home)page and two parallel sites to cater to both languages.

Since it looks like you need to localize for each language, then I guess this is the best way to go about it.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#12 2017-03-13 23:24:47

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

The quote came from http://community.theturninggate.net/vie … hp?id=6898

Not too sure how it would work...

Got the "en" link to lead to the Gallery page but can't get any formatting done. Also, why is on of the thumbnails indicate that it leads to ..."Gallery" instead of "CATIMINI" and both are locked, no less.
The point of this page is to list the videos, with descriptive thumbnails that would lead to the videos themselves in the Theater module.
I thought that by creating albums in Publisher, I could then upload the videos in their appropriate folders...

Last edited by pideja (2017-03-14 00:06:18)

Offline

#13 2017-03-14 00:30:45

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

Got the "en" link to lead to the Gallery page but can't get any formatting done. Also, why is on of the thumbnails indicate that it leads to ..."Gallery" instead of "CATIMINI" and both are locked, no less.

that page is formatted. It's using the standard Backlight page template. Did you assign a page template to that top-level gallery?

the link on that first thumbnail leads to Catimini. The Album title is Galeries. Check in Publisher (Lightroom) for the album title.

Check to make sure you've not enabled password protection under the album's Features tab.

The point of this page is to list the videos, with descriptive thumbnails that would lead to the videos themselves in the Theater module.
I thought that by creating albums in Publisher, I could then upload the videos in their appropriate folders...

Have you seen the documentation:
HTML5 Video: http://backlight.theturninggate.net/doc … ding_html5
note that all HTML5 videos go into one folder.

YouTube and Vimeo: http://backlight.theturninggate.net/doc … eo_youtube


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#14 2017-03-14 00:47:44

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

The quote came from http://community.theturninggate.net/vie … hp?id=6898

Not too sure how it would work...

That was a conversation about a multisite installation. There are probably a few ways to go about it. But since you need to localize language for each site, what you're doing is probably the best (only?) way to do it.

The comment about using the TTG Responsive Grid was based on a desire to replicate the old autoindex enabler plug-in.
Basically, what was needed was a portal to individual sites from one "landing page". One solution is just using plain text links to take the visitor to the individual sites.
Another, more attractive, solution was using the responsive grid to create a page with a grid of images with text, each grid linked to a separate site.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#15 2017-03-14 02:31:16

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

The Home page links work well, although the Gallery, Bio and Contact+CV pages do not display the formatting I require. What's strange is that clicking the thumbnails leads to another gallery page that is correctly formatted! Also, the large image should be a video but I cannot configure the Theater page because the is no “Backlight Theater” type to choose.

Offline

#16 2017-03-14 03:06:39

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

For your home page video, you first need to publish a Theater based album that contains the video.
Then insert that album in to the home page.

The reason the Galleries page is not styled like the home page is that you've not assigned an album set template to it. You need to create an album set template that uses the same page template as your home page.
Then go to Publisher > Top Level Galleries and click on "Galleries". Then click on Edit Properties. On that page you'll see where you can assign an album set template

The reason your other pages don't look right looks to be because you've not created them yet and you're getting a 404 Page Not Found error.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#17 2017-03-14 03:46:27

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

The Home page is fine. As well as the gallery page with the descriptive thumbnails. Thank you for your help. I still have to figure out how to place all the descriptive text within these boxes.

The thumbnails within the gallery page should link to videos rather than a large image of the thumbnail.
I placed the theater module folder within the backlight/modules folder. I have also created a videosrc folder in the galleries folder. That is where I placed the video files.

As for the Bio and Contact pages, for the moment, I fail to see why they don't show up. It's bound to be a small error that eventually I will find.

Offline

#18 2017-03-14 04:35:20

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

The Home page is fine. As well as the gallery page with the descriptive thumbnails. Thank you for your help. I still have to figure out how to place all the descriptive text within these boxes.

which "boxes"? When you create the page you can add text in the Page Copy tab.

I placed the theater module folder within the backlight/modules folder. I have also created a videosrc folder in the galleries folder. That is where I placed the video files.

There's more to it than that. You need to create a Theater album template. After that, create an album in Publisher using that template. You can hide the album from the Galleries album set on the Features tab of the create/edit album dialog.
Also, re-read the documentation, the videosrc/ folder does not go inside of the galleries/ folder. It should be on the same server level.

As for the Bio and Contact pages, for the moment, I fail to see why they don't show up. It's bound to be a small error that eventually I will find.

did you create those pages in the nat/en installation of Backlight?
If not, if they've been created elsewhere, you can just provide the url to those pages in the navigation menu item. Edit the menu set and for that item chose URL in the Linked To drop down.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#19 2017-03-14 06:11:32

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

I did find these pages under in the nat/ installation:
http://pideja.ca/nat/about/
http://pideja.ca/nat/contact/
you can link to those or create language specific pages in each of the nat/en and nat/fr Backlight installations.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#20 2017-03-16 00:22:52

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

I installed the module-theater  in  /backlight/modules. Created the theater template as a Backlight Theater type module.
I put the videosrc folder within pideja.ca/en. This now includes the folders backlight, galleries, videosrc and the index.php. Is this correct?

did you create those pages in the nat/en installation of Backlight?

I created the Bio and Contact + CV pages in Backlight. They should be in http://pideja.ca/nat/en/bio/ and http://pideja.ca/nat/en/contact/

Eventually, the same setup (when it finally works) will be replicated on the French side, whit adjustments for URLs and French menus, etc.

The http://pideja.ca/nat should only have the FR and En links to lead to the corresponding language section.

I did this in CE4 and although I had a hard time with some aspects of formatting, I don't recall so much trouble when converting to Backlight.
I think I should go over everything...I've got to find these mistakes.

Offline

#21 2017-03-16 01:04:26

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

Same question as the other thread: did you upload the index.php and .htaccess files to the /nat/en/ folder?

I put the videosrc folder within pideja.ca/en

Do you mean the pideja.com/nat/en/ folder?
When you created the Theater template, did you choose the HTML5 Video option? Are you including the necessary file formats?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

#22 2017-03-16 01:11:45

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 744
Website

Re: image on home page not displaying

Maybe the easiest is to restart with a new install. First create your /en/ pages with Backlight installed in /en/backlight. When this is working, create your french pages in /fr/ with a new Backlight installation in /fr/backlight. You will able to share your design templates from /en/. So that will be much less work. Finally create your entry page in / with Backlight installed in /backlight.

This way, you will avoid the confusion of where which page is set etc.

Just my 2 cents.


Daniel Leu | Photography   
DanielLeu.com

Just a user who loves to dive into techie stuff... and sometimes gets into trouble for that.

Offline

#23 2017-03-16 01:47:31

Daniel Leu
Moderator
Registered: 2012-10-11
Posts: 744
Website

Re: image on home page not displaying

Food for thoughts: Maybe you can do everything with one backlight install!

Concept: Custom pages reside in the root of your site, but you can't put them into a subdirectory such like /en. But you can have a hierarchy using Album Sets and Albums without images:

  /backlight
  /en <= album set, all containing albums or album sets have "Hide from Album Set" selected
  /en/about <= album with no images, text entered in album properties in lightroom
  /en/xxx <= dito for all your other pages
  /en/galleries <= gallery set with all your albums or more album sets
  /fr/ <= album set, content not visible
  /fr/...etc 

So the idea is really to use Albums as Pages but not using their images feature by not assigning any images.

With Backlight, you can have more than one menu! So design a menu for your english and one for your french pages. Then assign them to their respective templates.

One limitation are contact pages. Maybe you are okay with having something like contact_en and contact_fr in your root directory. Maybe there are other limitations... but I can't think of anything right now.

I currently use a similar structure at http://danielleu.com/shop/. /shop is an album set with /shop/greeting-cards being an album. (Eventually, each product will be an album with more infos).

Maybe this would work for you, maybe not. Have fun!


Daniel Leu | Photography   
DanielLeu.com

Just a user who loves to dive into techie stuff... and sometimes gets into trouble for that.

Offline

#24 2017-03-16 02:01:40

pideja
Member
From: Montreal
Registered: 2013-02-26
Posts: 428

Re: image on home page not displaying

Inching my way, the pages now show up, sort of, after having inserted the .htaccess file as you suggested, Rod. But, although the general look & feel of the pages is ok, I still get the 404 in Bio (About/) page and on the Contact page, there is dummy type were no text has been added while creating the Contact template, in Page Settings/Page Copy. There should be text and an image in the Bio page.

Last edited by pideja (2017-03-16 02:05:34)

Offline

#25 2017-03-16 02:11:40

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 13,498
Website

Re: image on home page not displaying

Hard to tell without seeing what's going on in the back end.
I'll be happy to take a look if you want to email your backlight credentials.

are you making your page changes in the /nat/en/ installation of Backlight? Because I'm not seeing any dummy text on the Contact page, just a contact form.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 1.1.1 test site, Pangolin test site

Offline

Board footer

Powered by FluxBB