Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-07-16 00:53:51

Samoreen
Member
From: Samoreau, France
Registered: 2015-04-22
Posts: 134
Website

[forum] "Mark this forum as read" not sticky

Hi,

Since a few days, it seems that "Mark this forum as read" is no longer sticky. When clicking on it, all topics appear as read but when I come back later to the forum, some messages already read (title displayed in gray) have the blue square icon.

Also, messages that I have not actually read before clicking on "Mark this forum as read" show up again as unread when coming back later to the forum.

[using Firefox]


Patrick

Offline

#2 2016-07-16 01:15:14

Samoreen
Member
From: Samoreau, France
Registered: 2015-04-22
Posts: 134
Website

Re: [forum] "Mark this forum as read" not sticky

It just happened again a few minutes ago.


Patrick

Offline

#3 2016-07-16 11:59:57

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 4,691
Website

Re: [forum] "Mark this forum as read" not sticky

Probably because someone posted something new to the thread.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#4 2016-07-16 18:13:33

Samoreen
Member
From: Samoreau, France
Registered: 2015-04-22
Posts: 134
Website

Re: [forum] "Mark this forum as read" not sticky

Please Matt, I know how a forum software works.

Once I have read all messages in a thread or once I have marked a forum or all forums has read, only the threads having a new message should get the blue square icon. So if a thread get that icon and if no new message has been posted to that thread and if no message has been edited, there should be no blue square. So there's something strange here.

Once I have read all messages in a thread, the thread title is listed in gray and it no longer has the blue square icon. So what if a thread title has no new message or no newly edited message, is listed in gray and has the blue square anyway?

I'm accessing the forum from various devices and browsers. I have also noticed that the blue square icon may be there for a given thread on one device and not on the other. For example, while I'm writing this, I observe that on my iPad, one thread in the Backlight support forum has the blue square icon on the iPad (even after a refresh), while it doesn't on my PC (because I have actually already read it). This implies that some information about the read/unread status could be stored as a cookie on the device. Which is not usual for a forum software. That information belongs to the forum database.


Patrick

Offline

#5 2016-07-16 19:22:31

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,084

Re: [forum] "Mark this forum as read" not sticky

I've long assumed the forum is maintaining some state via cookies, so that's why the status changes from device to device.

Offline

#6 2016-07-16 19:37:34

Samoreen
Member
From: Samoreau, France
Registered: 2015-04-22
Posts: 134
Website

Re: [forum] "Mark this forum as read" not sticky

Ben wrote:

I've long assumed the forum is maintaining some state via cookies, so that's why the status changes from device to device.

Confirmed. Very strange choice from the FluxBB author. I have just read information about this in some FluxBB related documents. Since cookies are used, the read/unread status not only depends on the device but also on the way cookies are managed in the browser. The result can therefore only be messy. Which is the case for me and explains what I observed.

A FluxBB mod has been published that allows to reproduce read/unread status management of phpbb, which is more understandable for the user : http://fluxbb.fr/forums/viewtopic.php?id=12883 .


Patrick

Offline

Board footer

Powered by FluxBB