Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-05-11 20:46:31

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 367
Website

Backlight 101 throws this error on startup

Just updated to 101 from 100. Logging in to backlight goes well. Starting the site gives me this error:

Something went wrong

Unexpected error: Class 'Album' not found in PageController.php on line 80

Please report error at http://community.theturninggate.net

There a way around this?
Thanx, Mark

Oh, by the way, this is now running in a subdomain for testing here:
http://backlightmhp.markhoffmanphotography.com

Last edited by markh (2016-05-11 20:48:10)

Offline

#2 2016-05-11 20:50:46

alfred
Member
Registered: 2013-06-08
Posts: 128

Re: Backlight 101 throws this error on startup

Get the same error message when trying to access the "About" page after the update.

Offline

#3 2016-05-11 21:00:03

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 16,174
Website

Re: Backlight 101 throws this error on startup

Did you perform the final step of the update: clearing template cache?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight 2 test site, Pangolin test site

Offline

#4 2016-05-11 21:02:52

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 367
Website

Re: Backlight 101 throws this error on startup

Yup. And it seemed to go as expected. I can also log into Backlight on the site as usual.

Offline

#5 2016-05-11 21:24:58

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,933

Re: Backlight 101 throws this error on startup

The support for embedded albums wrongly assumes your menu has a link to an album set or an album.  I'll need to fix this.

In the mean time, if you have a menu item linking to your Galleries, edit the Menu Set, and change the 'Link to' to 'Album Set', with the next field to 'Galleries':

menu.png

Offline

#6 2016-05-11 21:28:49

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 367
Website

Re: Backlight 101 throws this error on startup

That's fixed it. Thanks Ben.

Offline

#7 2016-05-11 21:34:56

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,933

Re: Backlight 101 throws this error on startup

That's great, Mark.  I have updated the Backlight zip file.  This includes only one altered file: backlight/designer/application/controllers/PageController.php, that removes this dependency on the menu include links to albums or album sets.

Offline

#8 2016-05-11 21:37:52

markh
Member
From: Center of The US
Registered: 2012-09-24
Posts: 367
Website

Re: Backlight 101 throws this error on startup

I'll grab it. Thanks again.

Offline

#9 2016-05-11 22:08:09

tomowensphoto
Member
From: Suffolk
Registered: 2012-11-21
Posts: 258
Website

Re: Backlight 101 throws this error on startup

I got the same error and the temporary fix fixed it


Regards,
TomO
Just a simple photographer
Live site at http://tomowens.openpoint.co.uk/

Offline

#10 2016-05-11 22:12:40

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,933

Re: Backlight 101 throws this error on startup

Hi Tom,  also try applying the updated file if you can.

Offline

#11 2016-05-11 23:32:25

tomowensphoto
Member
From: Suffolk
Registered: 2012-11-21
Posts: 258
Website

Re: Backlight 101 throws this error on startup

Hi Ben,
Just done that. Replaced the one file and set the menu back to URL & galleries/ and back to normal thanks.
TomO


Regards,
TomO
Just a simple photographer
Live site at http://tomowens.openpoint.co.uk/

Offline

Board footer

Powered by FluxBB