Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2016-05-07 03:37:38

Yakima77
Member
Registered: 2016-05-07
Posts: 5

Installation is not fuctional

I've installed Backlight+Pages in a subdirectory (/photos). I want to retain a well-established homepage. A root-directory installation overides my existing index.html page.  My intent for the software is not commericial--just to share photos with friends and families. 

I am able to upload albums from Lightroom. However, the display looks nothing like the demos and lacks most functionality.  The only page that looks like the demo is the search page and it seems to function fine.  I am hosting a php-based genealogy program in another sub-directory of the same domain, without problem. When I use the Backlight dashboard to list Php modules (lazeut.com/?check), it just goes to my root homepage (perhaps a clue?). I would appreciate any thoughts as to resolve my problem

Richard

http://lazeut.com/photos/galleries/

Offline

#2 2016-05-07 04:43:21

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,060
Website

Re: Installation is not fuctional

Looks like the css file isn't loading. Is there any redirect going on in your /photos/ folder?

did you upload the index.php and .htaccess files to the /photos/ folder

Does your host comply with the TTG requirements?

Hosting
    Linux OS
    Apache server
    PHP 5.2.6 or newer
    SQLite and PDO modules enabled


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#3 2016-05-07 05:25:53

Yakima77
Member
Registered: 2016-05-07
Posts: 5

Re: Installation is not fuctional

I checked the Php Info and the hosting requirements are met (the host is at networksolutions.com).  Both the index.php and .htaccess files (from Pages) are in the /photos/ directory.  I've tried 4 clean installations, 2 to the root and 2 to /photos/ directory both with and without the Pages module.  Always the same result. The site url and company url in Backlight both point to http://www.lazeut.com/photos/ which was the install default.  There is a pre-exisitng .htaccess in the root directory. Its contents: "Options -Indexes."  Since the genealogy program works fine in the same environment, I'm baffled.  What should I look for that might cause a redirect?  Thanks.

Offline

#4 2016-05-07 05:31:44

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 15,060
Website

Re: Installation is not fuctional

It might be something in the site root .htaccess? I'm not an expert by any means.

You might try installing in a sub-domain rather than sub-folder.

Otherwise, wait a bit until Matt and Ben wake up on the other side of the world and can take a look. Ben may need FTP access as well as admin access to Backlight. To save time, you can email that stuff to him.
http://community.theturninggate.net/profile.php?id=101


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Pangolin test site, Backlight 1.1.1 test site

Offline

#5 2016-05-07 07:28:31

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,747

Re: Installation is not fuctional

There is something amiss with your server's configuration.  Links to index.php fail to load, such as this one attempting to load the stylesheet:

http://lazeut.com/photos/galleries/index.php?template=2&extension=css&name=style

However, removing index.php from the name works:

http://lazeut.com/photos/galleries/?template=2&extension=css&name=style

Do you know of any setting you may have added to a higher-level .htaccess file, or in your site's configuration that's preventing the loading of PHP files with the file name in the link?

I can take a look via FTP if it helps.

Offline

#6 2016-05-07 07:32:00

Yakima77
Member
Registered: 2016-05-07
Posts: 5

Re: Installation is not fuctional

I'd be glad to give you FTP access. Should I send you the ID and password in your "Contact the Authors" form?

Offline

#7 2016-05-07 07:33:23

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,747

Re: Installation is not fuctional

The best way to send them is via the Email link under my name.

Offline

#8 2016-05-07 14:09:33

Ben
Moderator
From: Melbourne, Australia
Registered: 2012-09-29
Posts: 3,747

Re: Installation is not fuctional

Thanks for the login.  I have found an issue with the .htaccess rule in /photos/.  After commenting out two lines in /photos/.htaccess, the page is now loading.  This same issue also exists in the URLs under /galleries/.
Can you email me a Backlight admin login, so I can try and change these as well?

Offline

#9 2016-05-08 09:17:12

Yakima77
Member
Registered: 2016-05-07
Posts: 5

Re: Installation is not fuctional

Ben, thanks for your prompt resolution of the issues with my installation. I'm looking forward to populating the site properly over the next few days.  Richard

Offline

Board footer

Powered by FluxBB