Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 2015-09-04 04:25:09

slimblock
Member
Registered: 2015-08-26
Posts: 11

auto index pages not displaying vertically on iPhone

I have two auto index pages on my website, http://www.gentieu.com — galleries and tearsheets. I have them in Freewall style and I like the way they look on the desktop computer. But nothing shows up at all on my iPhone when viewed in a vertical position. They show up in a horizontal position.

I had just gotten the auto indexes to look the way I wanted with the Freewall style — they were sometimes showing up as Descriptive — (which is how they were always coming up on the iPhone) What I did to change that was, some of the links pointed to /galleries — and some pointed to /galleries.php.  the galleries.php displayed the Descriptive.  So I changed them all to /galleries/ and the Freewall style showed up. 

So I’m not really sure if maybe some of the thumbnails are too big, or what other big mess I made. And I’m wondering if I installed the auto index properly. It’s installed in the two folders, galleries and tear sheets, and also in the root folder.

Thanks very much for this helpful forum.

Penny

Offline

#2 2015-09-04 04:58:12

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 12,556
Website

Re: auto index pages not displaying vertically on iPhone

galleries.php leads to the Galleries page created by Pages. To get the Masonry layout on that page you'd need to change the settings in Pages > Appearance > The Autoindex

Your current "galleries" page (at /galleries/index.php) is created with Autoindex. Things look pretty normal on my iPhone. Your album links are showing up in a vertical row both with the iPhone held vertically and horizontally.
Same with the "Tearsheets" page. Looks like what I'd expect.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight test site

Offline

#3 2015-09-04 06:10:11

slimblock
Member
Registered: 2015-08-26
Posts: 11

Re: auto index pages not displaying vertically on iPhone

Thanks Rod. It's weird, I don't get anything coming up when I hold the iPhone vertically but I'm glad it's working on yours.

Offline

#4 2015-09-05 07:04:09

slimblock
Member
Registered: 2015-08-26
Posts: 11

Re: auto index pages not displaying vertically on iPhone

Still trying to solve this problem, of nothing showing up on this page on my iPhone 5 when I hold it vertically:  http://www.gentieu.com/galleries/. Maybe it shows up on the newer phones because they are higher res? I'm wondering if it could have to do with big thumbnails, trying to load the desktop thumbnails, not the mobile thumbnails? Weird that it displays the page when the phone is held horizontally, but not vertically. But not sure of the thumbnail theory either because I cut the biggest ones down and no luck.

Offline

#5 2015-09-05 07:08:08

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 12,556
Website

Re: auto index pages not displaying vertically on iPhone

just opened the page in an iPhone 5 emulator and can see what you mean.
http://mobiletest.me/iphone_5_emulator/ … galleries/

Matt will need to look into it.


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight test site

Offline

#6 2015-09-05 07:27:10

rod barbee
Moderator
From: Port Ludlow, WA USA
Registered: 2012-09-24
Posts: 12,556
Website

Re: auto index pages not displaying vertically on iPhone

If I just change the browser width, there comes a point that the albums will realign vertically. If I keep making the browser width narrower, the albums disappear completely. Looks like there might be some css that's hiding the albums when hitting a certain media query width.

I don't see this same thing happening on a galleries.php page using the freewall layout, though the album cell width is smaller than what you've got.

this might have something to do with the album cell width. It might be that it's wider than the width of an iPhone 5 in portrait mode. Can you try narrowing the Cell Width?


Rod 
Just a user with way too much time on his hands.
www.rodbarbee.com
ttg-tips.com, Backlight test site

Offline

#7 2015-09-05 11:25:41

slimblock
Member
Registered: 2015-08-26
Posts: 11

Re: auto index pages not displaying vertically on iPhone

Thanks Rod -- really appreciate your help. I will look at that tomorrow when I'm fresh and report back.

Offline

#8 2015-09-05 13:41:00

Matthew
Administrator
From: Seoul, South Korea
Registered: 2012-09-24
Posts: 4,654
Website

Re: auto index pages not displaying vertically on iPhone

Probably your gallery entries are too large. Considering that the smallest iPhone has a 320-pixels-wide display, then your items (plus spacing) should accommodate that width. Presently, your items are 358-pixels-wide, including padding on either side.


Campagna Pictures, http://campagnapictures.com
The Turning Gate, http://theturninggate.net

Offline

#9 2015-09-06 05:01:38

slimblock
Member
Registered: 2015-08-26
Posts: 11

Re: auto index pages not displaying vertically on iPhone

It's fixed! It was Cell Width in the galleries/index.php, jquery script which was indeed set at 358. I made it 310 and it works great. It works ok with the big thumbnails too. (Is that what you meant, Matt, by gallery entries and items?) Thanks very much!

Last edited by slimblock (2015-09-06 05:03:13)

Offline

Board footer

Powered by FluxBB