Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-26 08:10:31

Thanks Rod.

I copied in the data folder from a backup and that triggered the updates - the site seems to be working again.

Strange - I definitely left the original /data and /custom folders in place when I uploaded the v2 installer but they seem to have been overwritten somewhere during the installation. Thanks all for the help.

#2 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-25 22:38:55

So it seems the upgrade has somehow trashed the original site. I have the content on a backup but it would be disappointing to have to rebuild the site again.

Should there be an Upgrade Database link in each of the sections (Admin, Publisher and Designer) as per the upgrade instructions? That feels like the logical step to get Backlight 2 to recognise the v1 content, but there's nothing in the menus and all options are set to the standard defaults as if it was a fresh install.

Am I missing something?

#3 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-25 17:26:21

Ok. Thanks. That did the trick.

Now I'm in and trying to follow the upgrade instructions...
"Visit each of the Admin, Publisher and Designer menu items to upgrade the databases"

There are no "Upgrade database" menu items. Is this done automatically when I visit the root of each menu?

I guess not as I tried that and the site comes up as a new instance - no galleries and only default pages.

EDIT: Just checked and the v1 database is still intact. Phew...

#4 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-25 12:04:04

*bump*

After upgrading to Backlight 2 and trying to login with admin/ttg8888 I'm getting the following message (with a Backlight 2 header on the page so I'm assuming the lock is from Backlight and not the hosting)

"This account is locked.
This account has been locked due to a large number of failed login attempts.

To unlock this account, click Send Unlock Link, below. You will receive a link via email that can be used to unlock your account."

I've clicked the unlock link but no email comes through to the address linked with the account.

The site has now been down for a couple of days.

#5 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-24 22:36:43

Spoke too soon.

Backlight 2 is now installed but I'm unable to log in to the admin.

admin/ttg8888 doesn't work and neither does my existing user/password.

Backlight now says the account is locked due to too many failed login attempts and offers a link to send an unlock email yet nothing comes through.

I'm a pretty seasoned web developer trying to set this up for a client as a favour and hitting a lot of hurdles.

Any help/advice is appreciated.

#6 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-24 15:07:56

Thanks Ben. You were correct. The host had blocked the IP. All working now...

#7 Re: Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-23 16:09:16

Note: the .htaccess files etc. are all in the correct places.

#8 Backlight 2 Support » Problems Upgrading from v1 - v2 » 2018-09-23 15:51:45

soupmedia
Replies: 10

I'm trying to upgrade from V1 to v2. I've uploaded the v2 files but when I try to run the installer and enter the order number and email address I'm getting the following...

The installer was unable to connect to the server: https://get.theturninggate.net/install/has_backlight/

Any ideas?

#9 Re: Backlight Support » Cart not working » 2018-08-08 13:51:11

Thanks again Rod. The cart has been enabled in the album template. Is there somewhere else that it needs to be enabled? In Lightroom perhaps?

#11 Backlight Support » Cart not working » 2018-08-08 09:58:28

soupmedia
Replies: 5

Hi, I have recently set up an instance of Backlight with both the Cart and Client Response but I'm having trouble getting the cart to work. I'm using a clone of the standard theme and have enabled the Cart addon. It gives me the options to include a package button etc, but not the option to include a cart button on each pic (as per the docs), rendering it useless. Any tips on getting this working?

Board footer

Powered by FluxBB