Community @ The Turning Gate

Support community for TTG plugins and products.

You are not logged in.

#1 Re: Backlight 2 Support » Some galleries are not displayed correctly on Android » 2019-08-24 02:12:26

I updated the Album Files and cleared the Template Cache.  That did it!  Thanks Rod

#2 Re: Backlight 2 Support » Some galleries are not displayed correctly on Android » 2019-08-23 11:19:47

This worked before the update.  I just looked and the Gallery albums use the same code (also generated by backlight).

#3 Backlight 2 Support » Some galleries are not displayed correctly on Android » 2019-08-23 03:29:50

hjrw
Replies: 4

Since upgrading to BL2, I just noticed that many albums are now displayed without graphics.  The information is there, but as links, not images or formatted text.  A typical link is www.photographs-now.com/photo-now-backlight/clubs/001-arizona-bmw-z-series-club/020-ajo-2015.

The standard galleries (under the Gallery menu item) seem to work.  The issue is with both Chrome and Firefox on Android 9.

Here is a screen capture

https://drive.google.com/file/d/11FkH3h … sp=sharing

Any ideas?  I have not modified the site recently...

Thanks,

-Herschel

Just noted that the link to the site does not open the specific page.  To get to an example page, go to www.photographs-now.com. select "Clubs" then "Arizona BMW Z-Series Club" then "Ajo Drive March 2016" (the third image).

#4 Re: Backlight 2 Support » Error when publishing from Lightroom » 2019-05-15 08:16:58

I noticed something when I tried to publish an album from Lightroom (Backlight 2).  I got a similar error message as wsawka, but noted that the version of TTG Publisher Plug-in was still 3.xx even though I had "added" the 4.xx version.  I then deleted the old one and installed the new one and all was well.  I don't think that the documentation says to uninstall the old version.

Hope that helps some fellow Backlighters.

#5 Re: Backlight 2 Support » Contact Form eMail fails » 2019-05-02 13:41:36

Yes...  nothing there.  The mail is there from the Test Email function.

Update.  I tried the contact form using Chrome rather than FireFox and the email was received.  I had already cleared cache from Firefox, but it had no effect. 

So I presume that the issue is resolved to some extent.

Thanks
-Herschel

#6 Re: Backlight 2 Support » Contact Form eMail fails » 2019-05-02 12:34:13

Thanks for the info.  I now have the "Send Test Email" working, using "mail," but from my contact form, I get an acknowledgment that the email was sent, but it is not received. 

Any suggestions?

Thanks
Herschel

#7 Backlight 2 Support » Contact Form eMail fails » 2019-04-30 07:59:20

hjrw
Replies: 4

When I upgraded to Backlight2 (from Backlight), the email send from the Contact Form is not sent.  I get the following information, but the email is not received.

to: web@photographs-now.com
subject: Test Message
message:

This is a test


headers:

From: "Photographs-Now, Inc." <info@photographs-now.com>
MIME-Version: 1.0
Content-type: text/html; charset=utf-8
Reply-To: info@photographs-now.com

My settings are

Email Configuration



Mail Send Type      mail
SMTP Host            smtpout.secureserver.net
SMTP Username    info@photographs-now.com
SMTP Password     [ hidden ]
SMTP Port            3535
SMTP Security Protocol    none

Changing the port to 80 also does not send the email. 

If I change to smpt,

Email Configuration



Mail Send Type       smtp
SMTP Host             smtpout.secureserver.net
SMTP Username     info@photographs-now.com
SMTP Password      [ hidden ]
SMTP Port              3535
SMTP Security Protocol    none

produces the following error


Something went wrong

fsockopen(): unable to connect to none://smtpout.secureserver.net:3535 (Unable to find the socket transport "none" - did you forget to enable it when you configured PHP?) in SMTP.php on line 125

Changing the port yields the same message (:25 rather than :3535).

I am able to send an email to web@photographs-now.com from Thunderbird (using the same settings) with no issue.  My hosting provider has indicated that the parameters that I am using are correct.

Any suggestions?

Thanks,
-Herschel

PS  I had no issues with the Contact Form in Backlight

#8 Re: Backlight 2 Support » "Hidden" album still being displayed » 2019-04-29 11:23:48

Thank you.  Appreciate the quick response.

#9 Backlight 2 Support » "Hidden" album still being displayed » 2019-04-29 10:58:44

hjrw
Replies: 2

I finally upgraded from Backlight to Backlight2 this weekend.

My main gallery page displays an image from each album set.  Upon upgrading from Backlight to Backlight2, the albums which are designated as "hidden," are still displayed.  These are albums that display panoramic images.  The settings for these albums are noted here:

Features

    Enable Maps: Yes
    Enable Password: No
    Display Breadcrumbs: Yes
    Breadcrumb: Route 66 Pano Selector
    Hide From Album Set: Yes
    Hide From Search: Yes

The website is http://caddinfo.com/photo-now-backlight/.  It is the Galleries page.  The albums in question are near the bottom of the page with the designation "... Pano Selector."

Any assistance would be appreciated.

Thanks
-Herschel

#10 Re: PHPlugins » Custom Footer Error » 2018-03-19 09:01:16

Is there a way to get a border at the top of the custom footer?  The border command remains in the Footer options even with the Bottom Pallet / Copyright turned off, but doesn't do anything.  There does not seem to be a bottom border in Content Areas.

Also, where do I modify the size of the social media icons?

Thanks
-Herschel

#11 Re: PHPlugins » Custom Footer Error » 2018-03-17 06:36:57

Thanks Rod

That did it....   now on to tweaking it

-Herschel

#12 PHPlugins » Custom Footer Error » 2018-03-17 04:24:58

hjrw
Replies: 4

I am trying to use the custom footer scripts from Rod's TTG Tips & Tricks.  The code I inserted into the backlight.php file is below (I included lines above and below my insertion).  When I run it, I get the following error

    Something went wrong
    Unexpected error: syntax error, unexpected '<', expecting end of file in backlight.php on line 268
    Please report error at http://community.theturninggate.net

Notepad++ does not seem to indicate any issues.

What am I missing here?

-Herschel


function ttg_pallet_top_title( $style, $path ) {
  echo '

    <li class="logo"><a href="#"><ul class="logo_backlight">
        <li style="opacity:.85; top:75%; left:75%;"></li>
        <li style="opacity:.40; top:75%; left:50%;"></li>
                        ....
        <li style="opacity:.85; top: 0%; left:50%;"></li>
        <li style="opacity:.98; top: 0%; left: 0%; width: 50%; height: 50%"></li>
    </ul><h1><strong>B</strong>acklight</h1></a></li>

  ';
  return false;
} // END /**/

//----------------------------------------------------------------------------------------------
//Footer replacement

<div class="grid_12" id= "footer">                                           THIS IS LINE 268

<div class= "col_8">
<p>All content &copy;2015-' . date("Y") . '  HJR Weintraub, all rights reserved.
</br>Powered by <a href="http://theturninggate.net">The Turning Gate</a>
</div>

<div class="social-media-profiles social-media col_4">
<ul>
/*<li><a target="_blank" href="http://www.yoursite.com/blog/rss/" class="social_media fa fa-rss"></a></li>*/
/*<li><a target="_blank" href="https://www.instagram.com/your-profile/" class="social_media fa fa-instagram"></a></li>*/
<li><a target="_blank" href="https://www.facebook.com/Photographs-Now-152616671487325/" class="social_media fa fa-facebook"></a></li>
/*<li><a target="_blank" href="https://twitter.com/your-profile" class="social_media fa fa-twitter"></a></li>*/
</ul>

</div> <!-- #social-media-profiles -->

</div>

// ****************************************************************************************************
// END USER FUNCTIONS

?>

#13 PHPlugins » Changing from CE4 to Backlight for a php file » 2018-03-13 18:06:27

hjrw
Replies: 1

Under CE4, I had a php script (https://drive.google.com/file/d/1tWYeS7 … sp=sharing), wherein I had set up some conditional code to place StatCounter icons (with associated code to track users) on specific pages of the site.

A section of the CE4 code is below.  The conditional statements selected the various pages (HOME, GALLERIES. etc.).  What would the equivalent Backlight if / elseif code be?  The code listed for StatCounter is provided by StatCounter.  I will probably use Rod's Tips & Tricks code for a Custom Footer and would like to place the Statcounter icon on the right side, with the social icons to its left, and the Copyright notices and TTG citation on the left.

Any help would be appreciated

-Herschel

========================================================

// Add statcounter HOME
function ttg_footer_bottom ( $style, $path ) {
    if (G_STYLE == 'CE4-PAGES-HOME') {
        echo '

<!-- Start of StatCounter Code for Default Guide -->
    <script type="text/javascript">
    var sc_project=10262831;
    var sc_invisible=0;
    var sc_security="13728379";
    var scJsHost = (("https:" ==             document.location.protocol) ?
    "https://secure." : "http://www.");
    document.write("<sc"+"ript type=\'text/javascript\' src=\'" +
    scJsHost+
    "statcounter.com/counter/counter.js\'></"+"script>");
    </script>
    <noscript><div class="statcounter"><a title="shopify site
    analytics" href="http://statcounter.com/shopify/"
    target="_blank"><img class="statcounter"
    src="http://c.statcounter.com/10262831/0/13728379/0/"
    alt="shopify site analytics"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->

    ';
    return false;
}

// START NEW CODE

    elseif (G_PATH == 'CLUBS') {
        echo '

<!-- Start of StatCounter Code for Default Guide -->
    <script type="text/javascript">
    var sc_project=10266129;
    var sc_invisible=0;
    var sc_security="14491902";
    var scJsHost = (("https:" == document.location.protocol) ?
    "https://secure." : "http://www.");
    document.write("<sc"+"ript type=\'text/javascript\' src=\'" +
    scJsHost+
    "statcounter.com/counter/counter.js\'></"+"script>");
    </script>
    <noscript><div class="statcounter"><a title="web stats"
    href="http://statcounter.com/free-web-stats/"
    target="_blank"><img class="statcounter"
    src="http://c.statcounter.com/10266129/0/14491902/0/"
    alt="web stats"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->

    ';
    return false;
}

    elseif (G_STYLE == 'CE4-PAGES-GALLERIES') {
        echo '

    <!-- Start of StatCounter Code for Default Guide -->
    <script type="text/javascript">
    var sc_project=10266124;
    var sc_invisible=0;
    var sc_security="aa3309b5";

#14 Re: Backlight Support » Thumbnails for Album Sets » 2018-02-20 07:30:39

In the Edit Album dialog under Publisher in Lightroom, there is an entry for this image.  You can select any thumbnail that you have uploaded to the server or select Random, and it will randomly pick a photo.

This assumes that the photos and thumbnails have been uploaded (Published).

#15 Backlight Support » Download, GPS other buttons » 2018-02-20 05:45:26

hjrw
Replies: 2

Is there a simple way to place the download, gps and maybe other icons/buttons (as needed) on the top of the single image display next to the shopping cart icon?

#16 Backlight Support » Adding a counter to Backlight pages » 2018-02-03 13:01:09

hjrw
Replies: 1

In CE4, I used some php code to add a 'Statcounter' icon to several pages on my site.  The php code may be seen at this link

https://drive.google.com/file/d/1gRIMsg … sp=sharing

To locate the correct pages, it uses

function ttg_footer_bottom ( $style, $path ) {
    if (G_STYLE == 'CE4-PAGES-HOME') {
        echo '

elseif (G_PATH == 'CLUBS') {
        echo '

elseif (G_STYLE == 'CE4-PAGES-GALLERIES') {
        echo '

Will this work in Backlight?  Are these still appropriate variables to use in Backlight?

Here is a snipit of the php script

// Add statcounter HOME
function ttg_footer_bottom ( $style, $path ) {
    if (G_STYLE == 'CE4-PAGES-HOME') {
        echo '

<!-- Start of StatCounter Code for Default Guide -->
    <script type="text/javascript">
    var sc_project=10262831;
    var sc_invisible=0;
    var sc_security="13728379";
    var scJsHost = (("https:" ==             document.location.protocol) ?
    "https://secure." : "http://www.");
    document.write("<sc"+"ript type=\'text/javascript\' src=\'" +
    scJsHost+
    "statcounter.com/counter/counter.js\'></"+"script>");
    </script>
    <noscript><div class="statcounter"><a title="shopify site
    analytics" href="http://statcounter.com/shopify/"
    target="_blank"><img class="statcounter"
    src="http://c.statcounter.com/10262831/0/13728379/0/"
    alt="shopify site analytics"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->

    ';
    return false;
}

// START NEW CODE

    elseif (G_PATH == 'CLUBS') {
        echo '

<!-- Start of StatCounter Code for Default Guide -->


Thanks,
-Herschel

#17 Re: Backlight Support » Changing domain name » 2018-01-30 08:55:21

Is it possible to have it point to a page in the site or just the home page?

Also, how do I put this in htaccess  or html or php?

Thanks
-Herschel

#18 Backlight Support » Changing domain name » 2018-01-30 06:01:51

hjrw
Replies: 3

I have created my website in a new folder in my CPanel account.  I access it from caddinfo.com/photo-now-backlight for testing and modifying

I would like to now go live with the website, using photographsnow.com to access it.  I have set the domain to "point to" caddinfo.com/photo-now-backlight.  However, when I try the domain name (photographsnow.com), I get the main page, but the address for any selection that I make is photographsnow.com/photo-now-backlight/galleries/, and I get a 404 error, as the internal addresses within Backlight are caddinfo.com/photo-now-backlight/... .

Is there any way to correct this?

On a related note, I also have some domains that are intended to go to specific Album Set pages.  For example, I have rt-66.com which I would like to go to http://caddinfo.com/photo-now-backlight … 3-route-66.  I can get to that album set, but all images are missing, and selecting an Album produces a 404 error as it is trying to get to rt-66.com/galleries/003-route-66/ ... which does not exist.

Is there a way to force backlight to initialize from an Album Set page?

Thanks
-Herschel

#19 Re: Backlight Support » Drop Down Menu » 2018-01-26 11:14:51

I am using that on the album sets within the dropdown menu.  What I would like to do is eliminate all but the main navigation menu, but I would prefer to not delete the menu structure in case I want to use it later.

I have, for example

Galleries v
  Fireworks
  Route 66
  Grand Canyon

etc.  I would like it so hovering on Galleries does not produce the drop down

UPDATE

Got it.  I cloned the default menu set and removed the submenus from it.  Then reassigned the page templates to use this new menu set.  All is well now.

Thanks

#20 Backlight Support » Drop Down Menu » 2018-01-26 08:32:37

hjrw
Replies: 2

I created a menu set with drop downs.  I would like to remove the drop downs but keep the menu set.  I renamed it, cleared Template cache, cleared browser cache, but the drop downs are still there.

How do I turn the drop downs off, but keep the menu set should I decide to use them again?

Thanks
-Herschel

http://www.caddinfo.com/photo-now-backlight/

#21 Backlight Support » Side Pallet Length and download icon » 2018-01-17 14:53:55

hjrw
Replies: 1

I presume that there is a setting to change the length of the pallet.  Where would I find that setting?

CE4 placed the download icon on each thumbnail.  Backlight places it under the right-most icon in photo display mode.  Is it possible to add the download icon to each thumbnail again?

#22 Re: Backlight Support » Using an image as a link » 2018-01-16 09:40:45

If I reduce the browser width to the exact size of an image (a few slices), it still shows one image at a time...  when one clears the 'box' the next few slices that fit are displayed.  The box is shown with a dimension of about 280x48 when the image is sized to fill the box.  I'm not sure if I am looking at the image box or the entire content area.  No selection on the inspector highlights only the box.  If I make it narrower, the number of slices displayed is reduced.  I can only get it down to 239x72.

I think that the MOTO that my friend has is the same screen size as my Pixel 2XL, but I am not sure.

#23 Re: Backlight Support » Using an image as a link » 2018-01-16 07:22:04

I just noticed that on a smartphone there are issues with the panorama.  On my Pixel 2XL and my wife's Galaxy S8+, all works fine when you rotate the phone.  On the Galaxy S7 the display is in separate screen sized photos, not connected.  On a Droid Turbo 2, it is similar to the Galaxy.  A friend has the MOTO phone that takes attachments (camera, projector, etc) and it does not work on his.

Any suggestions for overcoming this issue?  I am running Oreo (8.1).

#24 Re: Backlight Support » Using an image as a link » 2018-01-16 02:58:41

UPDATE - Monday

Made link photos 2000 px wide, excluded the slice albums from search...  all is looking pretty good now. 

www.caddinfo.com/photo-now-backlight/galleries/009-mtts-2014/007-yosemite

Suggestions are appreciated.  (Design suggestions as well before this goes live.)

Herschel

#25 Re: Backlight Support » Using an image as a link » 2018-01-16 02:29:04

Thanks to all

I'll look at the sizes of the images.  I set the height , keeping the aspect ratio, to 400 pixels for the panorama slices.  I'll shrink the link photos to speed it up.  I'll also try a rename or since the pano slices are in their own albums, try excluding them from search.

Herschel

Board footer

Powered by FluxBB